mingw32-filesystem version 33.
[fedora-mingw.git] / example / mingw32-example.spec
1 %define __strip %{_mingw32_strip}
2 %define __objdump %{_mingw32_objdump}
3 %define _use_internal_dependency_generator 0
4 %define __find_requires %{_mingw32_findrequires}
5 %define __find_provides %{_mingw32_findprovides}
6
7 Name:           mingw32-example
8 Version:        1.2.3
9 Release:        1%{?dist}
10 Summary:        
11
12 License:        LGPLv2+
13 Group:          Development/Libraries
14 URL:            
15 Source0:        
16 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17
18 BuildArch:      noarch
19
20 BuildRequires:  mingw32-filesystem >= 33
21 BuildRequires:  mingw32-gcc
22 BuildRequires:  mingw32-binutils
23 # Any additional BuildRequires.
24
25
26 %description
27 # description
28
29
30 %prep
31 %setup -q
32
33
34 %build
35 %{_mingw32_configure}
36 make
37
38
39 %install
40 rm -rf $RPM_BUILD_ROOT
41 make DESTDIR=$RPM_BUILD_ROOT install
42
43 # Remove static libraries but DON'T remove *.dll.a files.
44 rm $RPM_BUILD_ROOT%{_mingw32_libdir}/libfoo.a
45
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50
51 %files
52 %defattr(-,root,root)
53 %{_mingw32_bindir}/foo.dll
54 %{_mingw32_libdir}/foo.dll.a
55 # etc.
56
57
58 %changelog
59 * Wed Sep 24 2008 Your Name <you@example.com> - 1.2.3-1
60 - Initial RPM release.