smock: add --overwrite option
[fedora-mingw.git] / example / mingw32-example.spec
1 %global __strip %{_mingw32_strip}
2 %global __objdump %{_mingw32_objdump}
3 %global _use_internal_dependency_generator 0
4 %global __find_requires %{_mingw32_findrequires}
5 %global __find_provides %{_mingw32_findprovides}
6
7 Name:           mingw32-example
8 Version:        1.2.3
9 Release:        1%{?dist}
10 Summary:        
11
12 License:        LGPLv2+
13 Group:          Development/Libraries
14
15 URL:            
16 Source0:        
17
18 # Patches from native Fedora package:
19 #Patch0: ...
20
21 # Patches for MinGW:
22 #Patch1000: ...
23
24 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
25 BuildArch:      noarch
26
27 BuildRequires:  mingw32-filesystem >= 35
28 BuildRequires:  mingw32-gcc
29 BuildRequires:  mingw32-binutils
30 # Any additional BuildRequires.
31
32
33 %description
34 # description
35
36
37 %prep
38 %setup -q
39
40
41 %build
42 %{_mingw32_configure} --disable-static
43 make %{?_smp_mflags}
44
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48 make DESTDIR=$RPM_BUILD_ROOT install
49
50 # Remove static libraries but DON'T remove *.dll.a files.
51 rm $RPM_BUILD_ROOT%{_mingw32_libdir}/libfoo.a
52
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57
58 %files
59 %defattr(-,root,root,-)
60 %doc LICENSE
61 %{_mingw32_bindir}/foo.dll
62 %{_mingw32_libdir}/foo.dll.a
63 # etc.
64
65
66 %changelog
67 * Sat Jun  6 2009 Your Name <you@example.com> - 1.2.3-1
68 - Initial RPM release.