mmalloc from last version to be included in gdb.
[ocaml-ancient.git] / mmalloc / configure.in
diff --git a/mmalloc/configure.in b/mmalloc/configure.in
new file mode 100644 (file)
index 0000000..2b5430e
--- /dev/null
@@ -0,0 +1,35 @@
+dnl Autoconf configure script for MMALLOC, the GNU mmemory allocator.
+dnl Copyright 2000 Free Software Foundation, Inc.
+dnl
+dnl This file is part of GDB.
+dnl 
+dnl This program is free software; you can redistribute it and/or modify
+dnl it under the terms of the GNU General Public License as published by
+dnl the Free Software Foundation; either version 2 of the License, or
+dnl (at your option) any later version.
+dnl 
+dnl This program is distributed in the hope that it will be useful,
+dnl but WITHOUT ANY WARRANTY; without even the implied warranty of
+dnl MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+dnl GNU General Public License for more details.
+dnl 
+dnl You should have received a copy of the GNU General Public License
+dnl along with this program; if not, write to the Free Software
+dnl Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+dnl Process this file with autoconf to produce a configure script.
+
+AC_PREREQ(2.12.1)dnl
+AC_INIT(mmalloc.c)
+
+AC_PROG_CC
+dnl AC_PROG_INSTALL
+AC_CHECK_TOOL(AR, ar)
+AC_CHECK_TOOL(RANLIB, ranlib, :)
+
+AC_FUNC_MMAP
+AC_CHECK_HEADERS(limits.h stddef.h unistd.h)
+
+dnl BFD_NEED_DECLARATION(sbrk)
+dnl BFD_NEED_DECLARATION(getpagesize)
+
+AC_OUTPUT(Makefile)