Rename base packages mingw -> mingw32.
[fedora-mingw.git] / w32api / mingw32-w32api.spec
1 %define __strip %{_mingw32_strip}
2 %define __objdump %{_mingw32_objdump}
3 %define _use_internal_dependency_generator 0
4 %define __find_requires %{_mingw32_findrequires}
5 %define __find_provides %{_mingw32_findprovides}
6
7 Name:           mingw32-w32api
8 Version:        3.11
9 Release:        7%{?dist}
10 Summary:        MinGW Windows cross-compiler Win32 header files
11
12 License:        Public Domain
13 Group:          Development/Libraries
14 URL:            http://www.mingw.org/
15 Source0:        http://dl.sourceforge.net/sourceforge/mingw/w32api-%{version}-src.tar.gz
16 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17
18 BuildArch:      noarch
19
20 BuildRequires:  mingw32-filesystem >= 23
21 BuildRequires:  mingw32-binutils
22 BuildRequires:  mingw32-gcc
23 BuildRequires:  mingw32-runtime
24
25 Requires:       mingw32-filesystem >= 23
26 Requires:       mingw32-binutils
27 Requires:       mingw32-gcc
28 Requires:       mingw32-runtime
29
30 # Once this is installed, mingw32-bootstrap (binary bootstrapper) is no
31 # longer needed.
32 Obsoletes:      mingw32-w32api-bootstrap
33 Obsoletes:      mingw-w32api-bootstrap
34
35 Provides:       mingw-w32api = %{version}-%{release}
36 Obsoletes:      mingw-w32api < 3.11-7
37
38
39 %description
40 MinGW Windows cross-compiler Win32 header files.
41
42
43 %prep
44 %setup -q -n w32api-%{version}
45
46 %build
47 ./configure \
48   --build=%_build \
49   --host=%{_mingw32_host}
50
51 make
52
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56
57 make prefix=$RPM_BUILD_ROOT%{_mingw32_prefix} install
58
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63
64 %files
65 %defattr(-,root,root)
66 %{_mingw32_includedir}/*
67 %{_mingw32_libdir}/*.a
68
69
70 %changelog
71 * Wed Sep 24 2008 Richard W.M. Jones <rjones@redhat.com> - 3.11-7
72 - Rename mingw -> mingw32.
73
74 * Wed Sep 10 2008 Richard W.M. Jones <rjones@redhat.com> - 3.11-6
75 - Moved ole provides to mingw-filesystem package.
76
77 * Thu Sep  4 2008 Richard W.M. Jones <rjones@redhat.com> - 3.11-3
78 - Use the RPM macros from mingw-filesystem.
79
80 * Mon Jul  7 2008 Richard W.M. Jones <rjones@redhat.com> - 3.11-2
81 - Initial RPM release, largely based on earlier work from several sources.