Add mingw(gdi32.dll) virtual provide
[fedora-mingw.git] / w32api / mingw-w32api.spec
1 %include /usr/lib/rpm/mingw-defs
2
3 Name:           mingw-w32api
4 Version:        3.11
5 Release:        3%{?dist}
6 Summary:        MinGW Windows cross-compiler Win32 header files
7
8 License:        Public Domain
9 Group:          Development/Libraries
10 URL:            http://www.mingw.org/
11 Source0:        http://dl.sourceforge.net/sourceforge/mingw/w32api-%{version}-src.tar.gz
12 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
13
14 BuildArch:      noarch
15
16 BuildRequires:  mingw-filesystem >= 3
17 BuildRequires:  mingw-binutils
18 BuildRequires:  mingw-gcc
19 BuildRequires:  mingw-runtime
20
21 Requires:       mingw-filesystem >= 3
22 Requires:       mingw-binutils
23 Requires:       mingw-gcc
24 Requires:       mingw-runtime
25
26 # Once this is installed, mingw-bootstrap (binary bootstrapper) is no
27 # longer needed.
28 Obsoletes:      mingw-bootstrap
29
30 #%define _use_internal_dependency_generator 0
31 #%define __debug_install_post %{nil}
32
33 # Fake provides, because wine/windows provides this, we don't have
34 # a real dep we can use
35 Provides: mingw(gdi32.dll)
36
37 %description
38 MinGW Windows cross-compiler Win32 header files.
39
40
41 %prep
42 %setup -q -n w32api-%{version}
43
44 %build
45 ./configure \
46   --build=%_build \
47   --host=%{_mingw_host}
48
49 make
50
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 make prefix=$RPM_BUILD_ROOT%{_mingw_prefix} install
56
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61
62 %files
63 %defattr(-,root,root)
64 %{_mingw_includedir}/*
65 %{_mingw_libdir}/*
66
67 %changelog
68 * Thu Sep  4 2008 Richard W.M. Jones <rjones@redhat.com> - 3.11-3
69 - Use the RPM macros from mingw-filesystem.
70
71 * Mon Jul  7 2008 Richard W.M. Jones <rjones@redhat.com> - 3.11-2
72 - Initial RPM release, largely based on earlier work from several sources.