smock: Document how to use it without httpd
[fedora-mingw.git] / virt-ctrl / mingw32-virt-ctrl.spec
1 %define __strip %{_mingw32_strip}
2 %define __objdump %{_mingw32_objdump}
3 %define _use_internal_dependency_generator 0
4 %define __find_requires %{_mingw32_findrequires}
5 %define __find_provides %{_mingw32_findprovides}
6
7 Name:           mingw32-virt-ctrl
8 Version:        1.0.3
9 Release:        2%{?dist}
10 Summary:        MinGW Windows port of virt-ctrl
11
12 License:        GPLv2+
13 Group:          Development/Libraries
14
15 URL:            http://et.redhat.com/~rjones/virt-ctrl/
16 Source0:        http://et.redhat.com/~rjones/virt-ctrl/files/virt-ctrl-%{version}.tar.gz
17
18 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
19 BuildArch:      noarch
20
21 BuildRequires:  mingw32-filesystem >= 35
22 BuildRequires:  mingw32-gcc
23 BuildRequires:  mingw32-binutils
24
25 BuildRequires:  mingw32-ocaml >= 3.11.0
26
27 BuildRequires:  mingw32-ocaml-lablgtk >= 2.10.1
28 BuildRequires:  mingw32-gtk2
29 BuildRequires:  gnome-icon-theme
30 BuildRequires:  mingw32-ocaml-dbus >= 0.06
31 BuildRequires:  mingw32-ocaml-libvirt
32 BuildRequires:  mingw32-ocaml-xml-light
33 BuildRequires:  mingw32-ocaml-extlib
34
35 # gettext support is disabled temporarily.
36 ## Tortuous list of BRs for gettext.
37 #BuildRequires:  ocaml-gettext-devel >= 0.3.0
38 #BuildRequires:  ocaml-fileutils-devel
39 #%ifnarch ppc64
40 #BuildRequires:  ocaml-camomile-data
41 #%endif
42
43
44 %description
45 Virt-ctrl is a graphical management app for virtual machines, modelled
46 after Virtual Machine Manager, but much more lightweight.
47
48
49 %prep
50 %setup -q -n virt-ctrl-%{version}
51
52
53 %build
54 # Workaround for non-tail-recursion in flexdll.
55 ulimit -s unlimited
56
57 export OCAMLFIND_CONF=%{_sysconfdir}/%{_mingw32_target}-ocamlfind.conf
58 export OCAMLC=%{_mingw32_target}-ocamlc
59 %{_mingw32_configure}
60 make opt
61
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65
66 export OCAMLFIND_CONF=%{_sysconfdir}/%{_mingw32_target}-ocamlfind.conf
67
68 make DESTDIR=$RPM_BUILD_ROOT install
69
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74
75 %files
76 %defattr(-,root,root)
77 %{_mingw32_bindir}/virt-ctrl
78
79
80 %changelog
81 * Fri Feb 20 2009 Richard W.M. Jones <rjones@redhat.com> - 1.0.3-2
82 - Rebuild for mingw32-gcc 4.4
83
84 * Mon Nov 24 2008 Richard W.M. Jones <rjones@redhat.com> - 1.0.1-1
85 - Initial RPM release.