termcap: Rename the library as libtermcap-0.dll for compatibility with
[fedora-mingw.git] / termcap / mingw32-termcap.spec
1 # Note: Termcap was deprecated and removed from Fedora after F-8.  It
2 # has been replaced by ncurses.  However ncurses cannot be compiled on
3 # Windows so we have to supply termcap.  In addition, the last stand-
4 # alone Fedora termcap package was actually just /etc/termcap from
5 # ncurses.  So here we are using the GNU termcap library which is
6 # regretably GPL'd.
7
8 %define __strip %{_mingw32_strip}
9 %define __objdump %{_mingw32_objdump}
10 %define _use_internal_dependency_generator 0
11 %define __find_requires %{_mingw32_findrequires}
12 %define __find_provides %{_mingw32_findprovides}
13
14 Name:           mingw32-termcap
15 Version:        1.3.1
16 Release:        3%{?dist}
17 Summary:        MinGW terminal feature database
18
19 License:        GPLv2+
20 Group:          Development/Libraries
21 URL:            ftp://ftp.gnu.org/gnu/termcap/
22 Source0:        ftp://ftp.gnu.org/gnu/termcap/termcap-%{version}.tar.gz
23 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
24
25 BuildArch:      noarch
26
27 BuildRequires:  mingw32-filesystem >= 28
28 BuildRequires:  mingw32-gcc
29 BuildRequires:  mingw32-binutils
30
31
32 %description
33 This is the GNU termcap library -- a library of C functions that
34 enable programs to send control strings to terminals in a way
35 independent of the terminal type.  The GNU termcap library does not
36 place an arbitrary limit on the size of termcap entries, unlike most
37 other termcap libraries.
38
39 This package contains libraries and development tools for the MinGW
40 cross-compiled version.
41
42
43 %prep
44 %setup -q -n termcap-%{version}
45
46
47 %build
48 %{_mingw32_configure}
49 make
50
51 # Build a shared library.  No need for -fPIC on Windows.
52 %{_mingw32_cc} -shared \
53   -Wl,--out-implib,libtermcap.dll.a \
54   -o libtermcap-0.dll \
55   termcap.o tparam.o version.o
56
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60
61 make install \
62   prefix=$RPM_BUILD_ROOT%{_mingw32_prefix} \
63   oldincludedir=
64
65 # Move the shared library to the correct locations.
66 mkdir -p $RPM_BUILD_ROOT%{_mingw32_bindir}
67 install -m 0755 libtermcap-0.dll $RPM_BUILD_ROOT%{_mingw32_bindir}
68 install -m 0755 libtermcap.dll.a $RPM_BUILD_ROOT%{_mingw32_libdir}
69
70 # Don't want the static library, thank you.
71 rm $RPM_BUILD_ROOT%{_mingw32_libdir}/libtermcap.a
72
73 # Move the info files to the correct location.
74 mkdir -p $RPM_BUILD_ROOT%{_mingw32_infodir}
75 mv $RPM_BUILD_ROOT%{_mingw32_prefix}/info/* $RPM_BUILD_ROOT%{_mingw32_infodir}
76
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81
82 %files
83 %defattr(-,root,root)
84 %{_mingw32_bindir}/libtermcap-0.dll
85 %{_mingw32_libdir}/libtermcap.dll.a
86 %{_mingw32_includedir}/termcap.h
87 # Note that we want the info files in this package because
88 # there is no equivalent native Fedora package.
89 %{_mingw32_infodir}/*
90
91
92 %changelog
93 * Fri Oct 31 2008 Richard W.M. Jones <rjones@redhat.com> - 1.3.1-3
94 - Fix so it builds a working DLL.
95
96 * Thu Sep 25 2008 Richard W.M. Jones <rjones@redhat.com> - 1.3.1-1
97 - Initial RPM release.