Replace %include of defs with explicit macros to avoid chicken+egg problem in mock...
[fedora-mingw.git] / runtime-bootstrap / mingw-runtime-bootstrap.spec
1 # NOTE: NOT a Fedora package.  This contains binaries which are needed
2 # just to bootstrap the whole system if you build everything from scratch.
3
4 %define __os_install_post /usr/lib/rpm/brp-compress %{nil}
5
6 %define runtime_version 3.14
7
8 Name:           mingw-runtime-bootstrap
9 Version:        1
10 Release:        3%{?dist}
11 Summary:        MinGW Windows bootstrap (binary package)
12
13 Group:          Development/Libraries
14 License:        Public Domain
15 URL:            http://www.mingw.org/
16
17 Source0:        http://dl.sourceforge.net/sourceforge/mingw/mingw-runtime-%{runtime_version}.tar.gz
18
19 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
20
21 Provides:       mingw-runtime = %{runtime_version}
22
23
24 %description
25 MinGW bootstrap (binary package).
26
27
28 %prep
29 %setup -q -c
30
31 %build
32 rm -rf i686-pc-mingw32
33
34 # Setup sys-root.
35 mkdir -p i686-pc-mingw32/sys-root/mingw
36 cp -a include lib i686-pc-mingw32/sys-root/mingw
37
38
39 %install
40 rm -rf $RPM_BUILD_ROOT
41
42 mkdir -p $RPM_BUILD_ROOT%{_prefix}
43 cp -a i686-pc-mingw32 $RPM_BUILD_ROOT%{_prefix}
44
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49
50 %files
51 %defattr(-,root,root)
52 %dir %{_prefix}/i686-pc-mingw32
53 %{_prefix}/i686-pc-mingw32/sys-root
54
55
56 %changelog
57 * Mon Jul  7 2008 Richard W.M. Jones <rjones@redhat.com> - 1-3
58 - Initial RPM release.