814595fb99693b519633f47dbb59f0bc11ce2240
[fedora-mingw.git] / qt-win / mingw32-qt-win.spec
1 %define __strip %{_mingw32_strip}
2 %define __objdump %{_mingw32_objdump}
3 %define _use_internal_dependency_generator 0
4 %define __find_requires %{_mingw32_findrequires}
5 %define __find_provides %{_mingw32_findprovides}
6
7 Name:           mingw32-qt-win
8 Version:        4.4.3
9 Release:        1%{?dist}
10 Summary:        Qt for Windows
11
12 License:        GPLv2+
13 Group:          Development/Libraries
14
15 URL:            http://www.qtsoftware.com/
16 Source0:        ftp://ftp.trolltech.no/qt/source/qt-win-opensource-src-%{version}.zip
17 Source1:        qt-win-configure.sh
18
19 # Qt-win is supplied with a binary configure.exe.  Although we have source
20 # for this, (a) it can't be compiled on Linux, and (b) we cannot run
21 # the Windows binary during the build.  Instead we run the command by
22 # hand and create this diff to record what it did.
23 #
24 # The full configure command we ran is in qt-win-configure.sh.
25 Patch0:         qt-win-configure.patch
26
27 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
28 BuildArch:      noarch
29
30 BuildRequires:  mingw32-filesystem >= 35
31 BuildRequires:  mingw32-gcc
32 BuildRequires:  mingw32-binutils
33
34 # For the native qmake program.
35 BuildRequires:  qt-devel
36
37
38 %description
39 This package contains the Qt software toolkit for developing
40 cross-platform applications.
41
42 This is the Windows version of Qt, for use in conjunction with the
43 Fedora Windows cross-compiler.
44
45
46 %prep
47 %setup -q -n qt-win-opensource-src-%{version}
48 %patch0 -p1
49
50
51 %build
52 make %{?_smp_mflags}
53
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57 make DESTDIR=$RPM_BUILD_ROOT install
58
59 # Remove static libraries but DON'T remove *.dll.a files.
60 rm $RPM_BUILD_ROOT%{_mingw32_libdir}/libfoo.a
61
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66
67 %files
68 %defattr(-,root,root)
69 %doc LICENSE
70 %{_mingw32_bindir}/foo.dll
71 %{_mingw32_libdir}/foo.dll.a
72 # etc.
73
74
75 %changelog
76 * Sun Feb  1 2009 Richard W.M. Jones <rjones@redhat.com> - 4.4.3-1
77 - Initial RPM release.