Use _smp_mflags and disable static libraries as appropriate.
[fedora-mingw.git] / portablexdr / mingw32-portablexdr.spec
1 %define __strip %{_mingw32_strip}
2 %define __objdump %{_mingw32_objdump}
3 %define _use_internal_dependency_generator 0
4 %define __find_requires %{_mingw32_findrequires}
5 %define __find_provides %{_mingw32_findprovides}
6
7 Name:           mingw32-portablexdr
8 Version:        4.0.11
9 Release:        2%{?dist}
10 Summary:        MinGW Windows PortableXDR XDR / RPC library
11
12 License:        LGPLv2+
13 Group:          Development/Libraries
14 URL:            http://et.redhat.com/~rjones/portablexdr/
15 Source0:        http://et.redhat.com/~rjones/portablexdr/portablexdr-%{version}.tar.gz
16 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17
18 BuildArch:      noarch
19
20 BuildRequires:  mingw32-filesystem >= 23
21 BuildRequires:  mingw32-gcc
22 BuildRequires:  mingw32-binutils
23
24
25 %description
26 MinGW Windows PortableXDR XDR / RPC library.
27
28
29 %prep
30 %setup -q -n portablexdr-%{version}
31
32
33 %build
34 %{_mingw32_configure} --disable-static
35 make %{?_smp_flags}
36
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40
41 make DESTDIR=$RPM_BUILD_ROOT install
42
43
44 %clean
45 rm -rf $RPM_BUILD_ROOT
46
47
48 %files
49 %defattr(-,root,root)
50 %{_mingw32_bindir}/libportablexdr-0.dll
51 %{_mingw32_libdir}/libportablexdr.dll.a
52 %{_mingw32_libdir}/libportablexdr.la
53 %{_mingw32_includedir}/rpc
54
55
56 %changelog
57 * Fri Jan 23 2009 Richard W.M. Jones <rjones@redhat.com> - 4.0.11-2
58 - Disable static libraries.
59 - Use _smp_flags.
60
61 * Wed Oct 15 2008 Richard W.M. Jones <rjones@redhat.com> - 4.0.11-1
62 - New upstream version 4.0.11.
63
64 * Wed Sep 24 2008 Richard W.M. Jones <rjones@redhat.com> - 4.0.10-5
65 - Rename mingw -> mingw32.
66
67 * Wed Sep 10 2008 Richard W.M. Jones <rjones@redhat.com> - 4.0.10-4
68 - Remove static library.
69
70 * Fri Sep  5 2008 Richard W.M. Jones <rjones@redhat.com> - 4.0.10-3
71 - Use RPM macros from mingw-filesystem.
72
73 * Tue Sep  2 2008 Daniel P. Berrange <berrange@redhat.com> - 4.0.10-2
74 - List files explicitly and set custom CFLAGS
75
76 * Tue Jul  8 2008 Richard W.M. Jones <rjones@redhat.com> - 4.0.10-1
77 - New upstream release 4.0.10.
78 - No need to manually install header files in this version.
79
80 * Mon Jul  7 2008 Richard W.M. Jones <rjones@redhat.com> - 4.0.9-2
81 - Initial RPM release, largely based on earlier work from several sources.