Replace %include of defs with explicit macros to avoid chicken+egg problem in mock...
[fedora-mingw.git] / portablexdr / mingw-portablexdr.spec
1 %define __strip %{_mingw_strip}
2 %define __objdump %{_mingw_objdump}
3 %define _use_internal_dependency_generator 0
4 %define __find_requires %{_mingw_findrequires}
5 %define __find_provides %{_mingw_findprovides}
6
7 Name:           mingw-portablexdr
8 Version:        4.0.10
9 Release:        4%{?dist}
10 Summary:        MinGW Windows PortableXDR XDR / RPC library
11
12 License:        LGPLv2+
13 Group:          Development/Libraries
14 URL:            http://et.redhat.com/~rjones/portablexdr/
15 Source0:        http://et.redhat.com/~rjones/portablexdr/portablexdr-%{version}.tar.gz
16 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17
18 BuildArch:      noarch
19
20 BuildRequires:  mingw-filesystem >= 23
21 BuildRequires:  mingw-gcc
22 BuildRequires:  mingw-binutils
23
24
25 %description
26 MinGW Windows PortableXDR XDR / RPC library.
27
28
29 %prep
30 %setup -q -n portablexdr-%{version}
31
32
33 %build
34 %{_mingw_configure}
35 make
36
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40
41 make DESTDIR=$RPM_BUILD_ROOT install
42
43 # Remove static library.
44 rm $RPM_BUILD_ROOT%{_mingw_libdir}/libportablexdr.a
45
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50
51 %files
52 %defattr(-,root,root)
53 %{_mingw_bindir}/libportablexdr-0.dll
54 %{_mingw_libdir}/libportablexdr.dll.a
55 %{_mingw_libdir}/libportablexdr.la
56 %{_mingw_includedir}/rpc
57
58
59 %changelog
60 * Wed Sep 10 2008 Richard W.M. Jones <rjones@redhat.com> - 4.0.10-4
61 - Remove static library.
62
63 * Fri Sep  5 2008 Richard W.M. Jones <rjones@redhat.com> - 4.0.10-3
64 - Use RPM macros from mingw-filesystem.
65
66 * Tue Sep  2 2008 Daniel P. Berrange <berrange@redhat.com> - 4.0.10-2
67 - List files explicitly and set custom CFLAGS
68
69 * Tue Jul  8 2008 Richard W.M. Jones <rjones@redhat.com> - 4.0.10-1
70 - New upstream release 4.0.10.
71 - No need to manually install header files in this version.
72
73 * Mon Jul  7 2008 Richard W.M. Jones <rjones@redhat.com> - 4.0.9-2
74 - Initial RPM release, largely based on earlier work from several sources.