Bump all spec releases for mass rebuild to mingw32-gcc 4.4
[fedora-mingw.git] / poco / mingw32-poco.spec
1 %define __strip %{_mingw32_strip}
2 %define __objdump %{_mingw32_objdump}
3 %define _use_internal_dependency_generator 0
4 %define __find_requires %{_mingw32_findrequires}
5 %define __find_provides %{_mingw32_findprovides}
6
7 Name:           mingw32-poco
8 Version:        1.3.3p1
9 Release:        3%{?dist}
10 Summary:        MinGW Windows C++ libraries for network-centric applications
11
12 License:        Boost
13 Group:          Development/Libraries
14 URL:            http://pocoproject.org/
15 Source0:        http://prdownloads.sourceforge.net/poco/poco-%{version}.tar.bz2
16 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17
18 Patch1001:      poco-01-buildsystem.patch
19 Patch1002:      poco-02-makefiles.patch
20 Patch1003:      poco-03-memcpy.patch
21
22 BuildArch:      noarch
23
24 BuildRequires:  mingw32-filesystem >= 33
25 BuildRequires:  mingw32-gcc
26 BuildRequires:  mingw32-gcc-c++
27 BuildRequires:  mingw32-binutils
28 BuildRequires:  mingw32-openssl
29
30
31 %description
32 POCO, the C++ Portable Components, is a collection of open source C++
33 class libraries that simplify and accelerate the development of
34 network-centric, portable applications in C++. The libraries integrate
35 perfectly with the C++ Standard Library and fill many of the
36 functional gaps left open by it. Their modular and efficient design
37 and implementation makes the C++ Portable Components extremely well
38 suited for embedded development, an area where the C++ programming
39 language is becoming increasingly popular, due to its suitability for
40 both low-level (device I/O, interrupt handlers, etc.) and high-level
41 object-oriented development. Of course, POCO is also ready for
42 enterprise-level challenges.
43
44 The POCO libraries free developers from re-inventing the wheel, and
45 allow them to spend their time on more worthwhile areas, such as
46 getting things done quickly and working on the features that make
47 their application unique.
48
49
50 %prep
51 %setup -q -n poco-%{version}
52
53 cp build/config/MinGW build/config/MinGW-cross
54 %patch1001 -p0
55 %patch1002 -p0
56 %patch1003 -p0
57
58
59 %build
60 ./configure --config=MinGW-cross --prefix=%{_mingw32_prefix}
61 make %{?_smp_flags}
62
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66 make DESTDIR=$RPM_BUILD_ROOT install
67
68 # *.dll files should be installed in %{_mingw32_bindir}.
69 mkdir -p $RPM_BUILD_ROOT%{_mingw32_bindir}
70 mv $RPM_BUILD_ROOT%{_mingw32_libdir}/*.dll $RPM_BUILD_ROOT%{_mingw32_bindir}/
71
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76
77 %files
78 %defattr(-,root,root)
79 %doc LICENSE
80 # XXX I think the '*d.dll' libraries are debug versions and
81 # possibly they should be moved to a subpackage?
82 %{_mingw32_bindir}/libPocoFoundationd.dll
83 %{_mingw32_bindir}/libPocoFoundation.dll
84 %{_mingw32_bindir}/libPocoNetd.dll
85 %{_mingw32_bindir}/libPocoNet.dll
86 %{_mingw32_bindir}/libPocoUtild.dll
87 %{_mingw32_bindir}/libPocoUtil.dll
88 %{_mingw32_bindir}/libPocoXMLd.dll
89 %{_mingw32_bindir}/libPocoXML.dll
90 %{_mingw32_libdir}/libPocoFoundationd.dll.a
91 %{_mingw32_libdir}/libPocoFoundation.dll.a
92 %{_mingw32_libdir}/libPocoNetd.dll.a
93 %{_mingw32_libdir}/libPocoNet.dll.a
94 %{_mingw32_libdir}/libPocoUtild.dll.a
95 %{_mingw32_libdir}/libPocoUtil.dll.a
96 %{_mingw32_libdir}/libPocoXMLd.dll.a
97 %{_mingw32_libdir}/libPocoXML.dll.a
98 %{_mingw32_includedir}/Poco
99
100
101 %changelog
102 * Fri Feb 20 2009 Richard W.M. Jones <rjones@redhat.com> - 1.3.3p1-3
103 - Rebuild for mingw32-gcc 4.4
104
105 * Fri Feb  6 2009 Richard W.M. Jones <rjones@redhat.com> - 1.3.3p1-2
106 - Include license.
107
108 * Sat Nov  8 2008 Richard W.M. Jones <rjones@redhat.com> - 1.3.3p1-1
109 - Initial RPM release.