smock: add --overwrite option
[fedora-mingw.git] / poco / mingw32-poco.spec
1 %define __strip %{_mingw32_strip}
2 %define __objdump %{_mingw32_objdump}
3 %define _use_internal_dependency_generator 0
4 %define __find_requires %{_mingw32_findrequires}
5 %define __find_provides %{_mingw32_findprovides}
6
7 Name:           mingw32-poco
8 Version:        1.3.3p1
9 Release:        4%{?dist}
10 Summary:        MinGW Windows C++ libraries for network-centric applications
11
12 License:        Boost
13 Group:          Development/Libraries
14 URL:            http://pocoproject.org/
15 Source0:        http://prdownloads.sourceforge.net/poco/poco-%{version}.tar.bz2
16 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17
18 Patch1001:      poco-01-buildsystem.patch
19 Patch1002:      poco-02-makefiles.patch
20 Patch1003:      poco-03-memcpy.patch
21 Patch1004:      poco-sprintf.patch
22
23 BuildArch:      noarch
24
25 BuildRequires:  mingw32-filesystem >= 33
26 BuildRequires:  mingw32-gcc
27 BuildRequires:  mingw32-gcc-c++
28 BuildRequires:  mingw32-binutils
29 BuildRequires:  mingw32-openssl
30
31
32 %description
33 POCO, the C++ Portable Components, is a collection of open source C++
34 class libraries that simplify and accelerate the development of
35 network-centric, portable applications in C++. The libraries integrate
36 perfectly with the C++ Standard Library and fill many of the
37 functional gaps left open by it. Their modular and efficient design
38 and implementation makes the C++ Portable Components extremely well
39 suited for embedded development, an area where the C++ programming
40 language is becoming increasingly popular, due to its suitability for
41 both low-level (device I/O, interrupt handlers, etc.) and high-level
42 object-oriented development. Of course, POCO is also ready for
43 enterprise-level challenges.
44
45 The POCO libraries free developers from re-inventing the wheel, and
46 allow them to spend their time on more worthwhile areas, such as
47 getting things done quickly and working on the features that make
48 their application unique.
49
50
51 %prep
52 %setup -q -n poco-%{version}
53
54 cp build/config/MinGW build/config/MinGW-cross
55 %patch1001 -p0
56 %patch1002 -p0
57 %patch1003 -p0
58 %patch1004 -p1
59
60
61 %build
62 ./configure --config=MinGW-cross --prefix=%{_mingw32_prefix}
63 make %{?_smp_flags}
64
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68 make DESTDIR=$RPM_BUILD_ROOT install
69
70 # *.dll files should be installed in %{_mingw32_bindir}.
71 mkdir -p $RPM_BUILD_ROOT%{_mingw32_bindir}
72 mv $RPM_BUILD_ROOT%{_mingw32_libdir}/*.dll $RPM_BUILD_ROOT%{_mingw32_bindir}/
73
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78
79 %files
80 %defattr(-,root,root)
81 %doc LICENSE
82 # XXX I think the '*d.dll' libraries are debug versions and
83 # possibly they should be moved to a subpackage?
84 %{_mingw32_bindir}/libPocoFoundationd.dll
85 %{_mingw32_bindir}/libPocoFoundation.dll
86 %{_mingw32_bindir}/libPocoNetd.dll
87 %{_mingw32_bindir}/libPocoNet.dll
88 %{_mingw32_bindir}/libPocoUtild.dll
89 %{_mingw32_bindir}/libPocoUtil.dll
90 %{_mingw32_bindir}/libPocoXMLd.dll
91 %{_mingw32_bindir}/libPocoXML.dll
92 %{_mingw32_libdir}/libPocoFoundationd.dll.a
93 %{_mingw32_libdir}/libPocoFoundation.dll.a
94 %{_mingw32_libdir}/libPocoNetd.dll.a
95 %{_mingw32_libdir}/libPocoNet.dll.a
96 %{_mingw32_libdir}/libPocoUtild.dll.a
97 %{_mingw32_libdir}/libPocoUtil.dll.a
98 %{_mingw32_libdir}/libPocoXMLd.dll.a
99 %{_mingw32_libdir}/libPocoXML.dll.a
100 %{_mingw32_includedir}/Poco
101
102
103 %changelog
104 * Sat Feb 21 2009 Richard W.M. Jones <rjones@redhat.com> - 1.3.3p1-4
105 - Rebuild for mingw32-gcc 4.4
106
107 * Fri Feb  6 2009 Richard W.M. Jones <rjones@redhat.com> - 1.3.3p1-2
108 - Include license.
109
110 * Sat Nov  8 2008 Richard W.M. Jones <rjones@redhat.com> - 1.3.3p1-1
111 - Initial RPM release.