Bump all spec releases for mass rebuild to mingw32-gcc 4.4
[fedora-mingw.git] / pidgin / mingw32-pidgin.spec
1 %define __strip %{_mingw32_strip}
2 %define __objdump %{_mingw32_objdump}
3 %define _use_internal_dependency_generator 0
4 %define __find_requires %{_mingw32_findrequires}
5 %define __find_provides %{_mingw32_findprovides}
6
7 Name:           mingw32-pidgin
8 Version:        2.5.2
9 Release:        2%{?dist}
10 Summary:        MinGW Windows port of Pidgin (ne Gaim)
11
12 License:        GPLv2+
13 Group:          Development/Libraries
14 URL:            http://www.pidgin.im/
15 Source0:        http://downloads.sourceforge.net/pidgin/pidgin-2.5.2.tar.bz2
16 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17
18 BuildArch:      noarch
19
20 BuildRequires:  mingw32-filesystem >= 33
21 BuildRequires:  mingw32-gcc
22 BuildRequires:  mingw32-binutils
23
24
25 %description
26 Pidgin is an instant messaging program for Windows, Linux, BSD, and
27 other Unixes. You can talk to your friends using AIM, ICQ,
28 Jabber/XMPP, MSN Messenger, Yahoo!, Bonjour, Gadu-Gadu, IRC, Novell
29 GroupWise Messenger, QQ, Lotus Sametime, SILC, SIMPLE, MySpaceIM, and
30 Zephyr.
31
32 Pidgin can log in to multiple accounts on multiple IM networks
33 simultaneously. This means that you can be chatting with friends on
34 AIM, talking to a friend on Yahoo Messenger, and sitting in an IRC
35 channel all at the same time.
36
37
38 %prep
39 %setup -q
40
41
42 %build
43 %{_mingw32_configure}
44 make
45
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 make DESTDIR=$RPM_BUILD_ROOT install
50
51 # Remove static libraries but DON'T remove *.dll.a files.
52 rm $RPM_BUILD_ROOT%{_mingw32_libdir}/libfoo.a
53
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58
59 %files
60 %defattr(-,root,root)
61 %{_mingw32_bindir}/foo.dll
62 %{_mingw32_libdir}/foo.dll.a
63 # etc.
64
65
66 %changelog
67 * Fri Feb 20 2009 Richard W.M. Jones <rjones@redhat.com> - 2.5.2-2
68 - Rebuild for mingw32-gcc 4.4
69
70 * Wed Sep 24 2008 Your Name <you@example.com> - 1.2.3-1
71 - Initial RPM release.