87d77590f5264ad4606f3a415bd4124d9128ed1b
[fedora-mingw.git] / pangomm / mingw32-pangomm.spec
1 %define __strip %{_mingw32_strip}
2 %define __objdump %{_mingw32_objdump}
3 %define _use_internal_dependency_generator 0
4 %define __find_requires %{_mingw32_findrequires}
5 %define __find_provides %{_mingw32_findprovides}
6
7 %define apiver 1.4
8
9 Name:           mingw32-pangomm
10 Version:        2.14.0
11 Release:        1%{?dist}
12 Summary:        MinGW Windows C++ interface for Pango
13
14 License:        LGPLv2+
15 Group:          Development/Libraries
16 URL:            http://gtkmm.sourceforge.net/
17 Source0:        http://ftp.gnome.org/pub/GNOME/sources/pangomm/2.14/pangomm-%{version}.tar.bz2
18 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
19
20 Patch0:         pangomm-2.14.0-devhelp.patch
21
22 BuildArch:      noarch
23
24 BuildRequires:  mingw32-filesystem >= 30
25 BuildRequires:  mingw32-gcc
26 BuildRequires:  mingw32-gcc-c++
27 BuildRequires:  mingw32-binutils
28 BuildRequires:  mingw32-glibmm24 >= 2.14.1
29 BuildRequires:  mingw32-cairomm >= 1.2.2
30 BuildRequires:  pango-devel >= 1.21.4
31 BuildRequires:  doxygen
32 BuildRequires:  graphviz
33
34
35 %description
36 pangomm provides a C++ interface to the Pango library. Highlights
37 include typesafe callbacks, widgets extensible via inheritance and a
38 comprehensive set of widget classes that can be freely combined to
39 quickly create complex user interfaces.
40
41
42 %prep
43 %setup -q -n pangomm-%{version}
44 %patch0 -p1 -b .devhelp
45
46
47 %build
48 %{_mingw32_configure} --disable-static
49 make
50
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54 make DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p" install
55
56 rm -r $RPM_BUILD_ROOT%{_mingw32_libdir}/pangomm-%{apiver}
57
58 # Remove documentation.
59 rm -r $RPM_BUILD_ROOT%{_mingw32_docdir}/pangomm-%{apiver}
60 rm -r $RPM_BUILD_ROOT%{_mingw32_datadir}/devhelp
61
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66
67 %files
68 %defattr(-,root,root)
69 %{_mingw32_bindir}/libpangomm-%{apiver}-1.dll
70 %{_mingw32_libdir}/libpangomm-%{apiver}.la
71 %{_mingw32_libdir}/libpangomm-%{apiver}.dll.a
72 %{_mingw32_libdir}/pkgconfig/pangomm-%{apiver}.pc
73 %{_mingw32_includedir}/pangomm-%{apiver}
74
75
76 %changelog
77 * Fri Oct 24 2008 Richard W.M. Jones <rjones@redhat.com> - 2.14.0-1
78 - Initial RPM release.