ae96a9a54d7fd044e1cc3709b4e1adf4629bede6
[fedora-mingw.git] / pango / mingw32-pango.spec
1 %define __strip %{_mingw32_strip}
2 %define __objdump %{_mingw32_objdump}
3 %define _use_internal_dependency_generator 0
4 %define __find_requires %{_mingw32_findrequires}
5 %define __find_provides %{_mingw32_findprovides}
6
7 Name:           mingw32-pango
8 Version:        1.22.1
9 Release:        4%{?dist}
10 Summary:        MinGW Windows Pango library
11
12 License:        LGPLv2+
13 Group:          Development/Libraries
14 URL:            http://www.pango.org
15 Source0:        http://download.gnome.org/sources/pango/1.21/pango-%{version}.tar.bz2
16
17 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
18
19 # Native pango uses a %post script to generate this, but the
20 # pango-querymodules.exe binary is not something we can easily run on
21 # a Linux host. We could use wine but wine isn't happy in a mock
22 # environment. So we just include a pre-generated copy on basis that
23 # it won't ever change much.
24 #
25 # If you want to rebuild this, do:
26 # wine %{_mingw32_bindir}/pango-querymodules.exe > pango.modules
27 Source1:        pango.modules
28
29 BuildArch:      noarch
30
31 BuildRequires:  mingw32-filesystem >= 23
32 BuildRequires:  mingw32-gcc
33 BuildRequires:  mingw32-binutils
34 BuildRequires:  mingw32-iconv
35 BuildRequires:  mingw32-gettext
36 BuildRequires:  mingw32-cairo >= 1.8.0
37 BuildRequires:  mingw32-freetype
38 BuildRequires:  mingw32-fontconfig
39 BuildRequires:  mingw32-glib2
40 BuildRequires:  pkgconfig
41
42 Requires:       pkgconfig
43
44
45 %description
46 MinGW Windows Pango library.
47
48
49 %prep
50 %setup -q -n pango-%{version}
51
52 %build
53 # Need to run the correct version of glib-mkenums.
54 PATH=%{_mingw32_bindir}:$PATH \
55 %{_mingw32_configure} --disable-static
56 make %{?_smp_mflags}
57
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61
62 make DESTDIR=$RPM_BUILD_ROOT install
63
64 mkdir -p $RPM_BUILD_ROOT%{_mingw32_sysconfdir}/pango/
65 cp %{SOURCE1} $RPM_BUILD_ROOT%{_mingw32_sysconfdir}/pango/
66
67 rm -f $RPM_BUILD_ROOT/%{_mingw32_libdir}/charset.alias
68
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %files
74 %defattr(-,root,root)
75 %doc COPYING
76 %{_mingw32_bindir}/libpango-1.0-0.dll
77 %{_mingw32_bindir}/libpangocairo-1.0-0.dll
78 %{_mingw32_bindir}/libpangoft2-1.0-0.dll
79 %{_mingw32_bindir}/libpangowin32-1.0-0.dll
80 %{_mingw32_bindir}/pango-querymodules.exe
81 %{_mingw32_includedir}/pango-1.0/
82 %{_mingw32_libdir}/libpango-1.0.dll.a
83 %{_mingw32_libdir}/libpango-1.0.la
84 %{_mingw32_libdir}/libpangocairo-1.0.dll.a
85 %{_mingw32_libdir}/libpangocairo-1.0.la
86 %{_mingw32_libdir}/libpangoft2-1.0.dll.a
87 %{_mingw32_libdir}/libpangoft2-1.0.la
88 %{_mingw32_libdir}/libpangowin32-1.0.dll.a
89 %{_mingw32_libdir}/libpangowin32-1.0.la
90 %{_mingw32_libdir}/pango-1.0.def
91 %{_mingw32_libdir}/pangocairo-1.0.def
92 %{_mingw32_libdir}/pangoft2-1.0.def
93 %{_mingw32_libdir}/pangowin32-1.0.def
94 %{_mingw32_libdir}/pango/
95 %{_mingw32_libdir}/pkgconfig/pango.pc
96 %{_mingw32_libdir}/pkgconfig/pangocairo.pc
97 %{_mingw32_libdir}/pkgconfig/pangoft2.pc
98 %{_mingw32_libdir}/pkgconfig/pangowin32.pc
99 %{_mingw32_datadir}/gtk-doc/html/pango/
100 %{_mingw32_mandir}/man1/pango-querymodules.1*
101 %{_mingw32_sysconfdir}/pango/
102
103
104 %changelog
105 * Fri Jan 30 2009 Richard W.M. Jones <rjones@redhat.com> - 1.22.1-4
106 - Requires pkgconfig.
107
108 * Tue Jan 27 2009 Levente Farkas <lfarkas@lfarkas.org> - 1.22.1-3
109 - Include license file in documentation section.
110
111 * Fri Jan 23 2009 Richard W.M. Jones <rjones@redhat.com> - 1.22.1-2
112 - Disable static libraries.
113 - Use _smp_mflags.
114
115 * Fri Oct 24 2008 Richard W.M. Jones <rjones@redhat.com> - 1.22.1-1
116 - New upstream version 1.22.1.
117 - BR cairo >= 1.8.0 because of important fixes.
118
119 * Wed Sep 24 2008 Richard W.M. Jones <rjones@redhat.com> - 1.21.6-6
120 - Rename mingw -> mingw32.
121
122 * Tue Sep 23 2008 Daniel P. Berrange <berrange@redhat.com> - 1.21.6-5
123 - Remove use of wine in %-post.
124
125 * Thu Sep 11 2008 Daniel P. Berrange <berrange@redhat.com> - 1.21.6-4
126 - Add dep on pkgconfig
127
128 * Thu Sep 11 2008 Richard W.M. Jones <rjones@redhat.com> - 1.21.6-3
129 - post/preun scripts to update the pango.modules list.
130
131 * Wed Sep 10 2008 Richard W.M. Jones <rjones@redhat.com> - 1.21.6-2
132 - Run the correct glib-mkenums.
133
134 * Tue Sep  9 2008 Daniel P. Berrange <berrange@redhat.com> - 1.21.6-1
135 - Initial RPM release