smock: add --overwrite option
[fedora-mingw.git] / ocaml-xml-light / mingw32-ocaml-xml-light.spec
1 %define __strip %{_mingw32_strip}
2 %define __objdump %{_mingw32_objdump}
3 %define _use_internal_dependency_generator 0
4 %define __find_requires %{_mingw32_findrequires}
5 %define __find_provides %{_mingw32_findprovides}
6
7 Name:           mingw32-ocaml-xml-light
8 Version:        2.2.cvs20070817
9 Release:        4%{?dist}
10 Summary:        MinGW Windows minimal XML parser and printer for OCaml
11
12 License:        LGPLv2+
13 Group:          Development/Libraries
14
15 URL:            http://tech.motion-twin.com/xmllight.html
16 Source0:        xml-light-%{version}.tar.gz
17
18 # Patches for MinGW:
19 Patch1000:      mingw32-ocaml-xml-light-2.2-build.patch
20
21 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
22 BuildArch:      noarch
23
24 BuildRequires:  mingw32-filesystem >= 35
25 BuildRequires:  mingw32-gcc
26 BuildRequires:  mingw32-binutils
27 BuildRequires:  mingw32-ocaml >= 3.11.0-0.15.beta1
28
29
30 %description
31 Xml-Light is a minimal XML parser & printer for OCaml. It provides
32 functions to parse an XML document into an OCaml data structure, work
33 with it, and print it back to an XML document. It support also DTD
34 parsing and checking, and is entirely written in OCaml, hence it does
35 not require additional C library.
36
37
38 %prep
39 %setup -q -c -n %{name}-%{version}
40
41 %patch1000 -p0
42
43
44 %build
45 ulimit -s unlimited
46
47 make opt
48 sed -e 's/@VERSION@/%{VERSION}/' < META.in > META
49
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 mkdir -p $RPM_BUILD_ROOT%{_libdir}/%{_mingw32_target}-ocaml/xml-light
55
56 install xml-light.cmxa xml-light.a *.mli *.cmi *.cmx \
57   $RPM_BUILD_ROOT%{_libdir}/%{_mingw32_target}-ocaml/xml-light
58 install META $RPM_BUILD_ROOT%{_libdir}/%{_mingw32_target}-ocaml/xml-light
59
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64
65 %files
66 %defattr(-,root,root)
67 %{_libdir}/%{_mingw32_target}-ocaml/xml-light/
68
69
70 %changelog
71 * Fri Feb 20 2009 Richard W.M. Jones <rjones@redhat.com> - 2.2.cvs20070817-4
72 - Rebuild for mingw32-gcc 4.4
73
74 * Sun Nov 23 2008 Richard W.M. Jones <rjones@redhat.com> - 2.2cvs20070817-3
75 - Rebuild against latest OCaml cross-compiler.
76
77 * Sun Nov 16 2008 Richard W.M. Jones <rjones@redhat.com> - 2.2cvs20070817-2
78 - Force rebuild against latest OCaml compiler.
79
80 * Sat Nov 15 2008 Richard W.M. Jones <rjones@redhat.com> - 2.2cvs20070817-1
81 - Initial RPM release.