Missing BR (discovered by mock)
[fedora-mingw.git] / nsis / mingw32-nsis.spec
1 %define sconsopts VERSION=%{version} PREFIX=%{_prefix} PREFIX_CONF=%{_sysconfdir} SKIPPLUGINS=System DEBUG_SYMBOLS=1 OPTS=1
2
3 Name:           mingw32-nsis
4 Version:        2.39
5 Release:        3%{?dist}
6 Summary:        MinGW Windows libxml2 XML processing library
7
8 License:        zlib and CPL
9 Group:          Development/Libraries
10 URL:            http://nsis.sourceforge.net/
11 Source0:        http://dl.sourceforge.net/sourceforge/nsis/nsis-%{version}-src.tar.bz2
12 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
13
14 # Patches from Debian (mainly by Paul Wise).
15 Patch0:         nsis-2.39-debian-64bit-fixes.patch
16 Patch1:         nsis-2.39-debian-debug-opt.patch
17
18 # This patch is required for NSIS to find the correct cross-compiler.
19 Patch100:       nsis-2.39-mingw32-search.patch
20
21 BuildRequires:  mingw32-filesystem >= 20
22 BuildRequires:  mingw32-gcc
23 BuildRequires:  mingw32-gcc-c++
24 BuildRequires:  mingw32-binutils
25 BuildRequires:  python
26 BuildRequires:  scons >= 0.96.93
27
28 # We build with 'gcc -m32' and that fails on 64 bit platforms when we
29 # include <gnu/stubs.h>.  On x86-64, this is provided by
30 # glibc-devel.i386.  Depend on the file explicitly, since only recent
31 # versions of RPM let you require a package by architecture.
32 BuildRequires:  /usr/include/gnu/stubs-32.h
33
34 # We really need the 32 bit version of this library.  The 64 bit
35 # version will definitely not work.  XXX Need to do the right thing on
36 # non-x86 architectures.
37 BuildRequires:  /usr/lib/libwx_baseu-2.8.so
38
39
40 %description
41 NSIS, the Nullsoft Scriptable Install System, is a script-driven
42 Windows installation system.
43
44 This package includes native Fedora binaries of makensis (etc.) and
45 all plugins except for System.dll.  The System.dll plugin cannot be
46 built natively at this time since it includes inline Microsoft
47 assembler code.
48
49
50 %prep
51 %setup -q -n nsis-%{version}-src
52
53 %patch0 -p1
54 %patch1 -p1
55
56 %patch100 -p1
57
58
59 %build
60 scons %{sconsopts}
61
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65
66 mkdir $RPM_BUILD_ROOT
67 scons %{sconsopts} PREFIX_DEST=$RPM_BUILD_ROOT install
68
69 mv $RPM_BUILD_ROOT%{_docdir}/nsis $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
70
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75
76 %files
77 %defattr(-,root,root)
78 %{_bindir}/*
79 %config(noreplace) %{_sysconfdir}/nsisconf.nsh
80 %{_includedir}/nsis
81 %doc %{_docdir}/%{name}-%{version}
82 %{_datadir}/nsis
83
84
85 %changelog
86 * Tue Oct  7 2008 Richard W.M. Jones <rjones@redhat.com> - 2.39-3
87 - Initial RPM release.