Updated NSIS to 2.43 (Levente Farkas).
[fedora-mingw.git] / nsis / mingw32-nsis.spec
1 %define sconsopts VERSION=%{version} PREFIX=%{_prefix} PREFIX_CONF=%{_sysconfdir} SKIPPLUGINS=System DEBUG_SYMBOLS=1 OPTS=1
2 %define _default_patch_fuzz 2
3
4 Name:           mingw32-nsis
5 Version:        2.43
6 Release:        1%{?dist}
7 Summary:        Nullsoft Scriptable Install System
8
9 License:        zlib and CPL
10 Group:          Development/Libraries
11 URL:            http://nsis.sourceforge.net/
12 Source0:        http://dl.sourceforge.net/sourceforge/nsis/nsis-%{version}-src.tar.bz2
13 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
14
15 # Patches from Debian (mainly by Paul Wise).
16 Patch0:         nsis-2.42-debian-64bit-fixes.patch
17 Patch1:         nsis-2.43-debian-debug-opt.patch
18
19 BuildRequires:  mingw32-filesystem >= 40
20 BuildRequires:  mingw32-gcc
21 BuildRequires:  mingw32-gcc-c++
22 BuildRequires:  mingw32-binutils
23 BuildRequires:  python
24 BuildRequires:  scons
25 BuildRequires:  wxGTK-devel
26
27 # since nsis a 32 bit only apps
28 ExclusiveArch:  i386 ppc
29
30 %description
31 NSIS, the Nullsoft Scriptable Install System, is a script-driven
32 Windows installation system.
33
34 This package includes native Fedora binaries of makensis (etc.) and
35 all plugins except for System.dll.  The System.dll plugin cannot be
36 built natively at this time since it includes inline Microsoft
37 assembler code.
38
39
40 %prep
41 %setup -q -n nsis-%{version}-src
42
43 %patch0 -p1 -b .64bit
44 %patch1 -p1 -b .debug
45
46
47 %build
48 scons %{sconsopts}
49
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 mkdir $RPM_BUILD_ROOT
55 scons %{sconsopts} PREFIX_DEST=$RPM_BUILD_ROOT install
56
57 mv $RPM_BUILD_ROOT%{_docdir}/nsis $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
58
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63
64 %files
65 %defattr(-,root,root)
66 %doc %{_docdir}/%{name}-%{version}
67 %config(noreplace) %{_sysconfdir}/nsisconf.nsh
68 %{_bindir}/*
69 #{_includedir}/nsis
70 %{_datadir}/nsis
71
72
73 %changelog
74 * Fri Feb 13 2009 Levente Farkas <lfarkas@lfarkas.org> - 2.43-1
75 - update to the latest upstream
76
77 * Wed Jan 14 2009 Levente Farkas <lfarkas@lfarkas.org> - 2.42-1
78 - update to the latest upstream
79 - a few small changes
80
81 * Fri Oct 17 2008 Richard W.M. Jones <rjones@redhat.com> - 2.39-5
82 - Fix the Summary line.
83
84 * Wed Oct  8 2008 Richard W.M. Jones <rjones@redhat.com> - 2.39-4
85 - Initial RPM release.