Express the 32 bit dependency on wxGTK-devel.
[fedora-mingw.git] / nsis / mingw32-nsis.spec
1 %define sconsopts VERSION=%{version} PREFIX=%{_prefix} PREFIX_CONF=%{_sysconfdir} SKIPPLUGINS=System DEBUG_SYMBOLS=1 OPTS=1
2
3 Name:           mingw32-nsis
4 Version:        2.39
5 Release:        2%{?dist}
6 Summary:        MinGW Windows libxml2 XML processing library
7
8 License:        zlib and CPL
9 Group:          Development/Libraries
10 URL:            http://nsis.sourceforge.net/
11 Source0:        http://dl.sourceforge.net/sourceforge/nsis/nsis-%{version}-src.tar.bz2
12 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
13
14 # Patches from Debian (mainly by Paul Wise).
15 Patch0:         nsis-2.39-debian-64bit-fixes.patch
16 Patch1:         nsis-2.39-debian-debug-opt.patch
17
18 # This patch is required for NSIS to find the correct cross-compiler.
19 Patch100:       nsis-2.39-mingw32-search.patch
20
21 BuildRequires:  mingw32-filesystem >= 20
22 BuildRequires:  mingw32-gcc
23 BuildRequires:  mingw32-binutils
24 BuildRequires:  python
25 BuildRequires:  scons >= 0.96.93
26
27 # We build with 'gcc -m32' and that fails on 64 bit platforms when we
28 # include <gnu/stubs.h>.  On x86-64, this is provided by
29 # glibc-devel.i386.  Depend on the file explicitly, since only recent
30 # versions of RPM let you require a package by architecture.
31 BuildRequires:  /usr/include/gnu/stubs-32.h
32
33 # We really need the 32 bit version of this library.  The 64 bit
34 # version will definitely not work.  XXX Need to do the right thing on
35 # non-x86 architectures.
36 BuildRequires:  /usr/lib/libwx_baseu-2.8.so
37
38
39 %description
40 NSIS, the Nullsoft Scriptable Install System, is a script-driven
41 Windows installation system.
42
43 This package includes native Fedora binaries of makensis (etc.) and
44 all plugins except for System.dll.  The System.dll plugin cannot be
45 built natively at this time since it includes inline Microsoft
46 assembler code.
47
48
49 %prep
50 %setup -q -n nsis-%{version}-src
51
52 %patch0 -p1
53 %patch1 -p1
54
55 %patch100 -p1
56
57
58 %build
59 scons %{sconsopts}
60
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64
65 mkdir $RPM_BUILD_ROOT
66 scons %{sconsopts} PREFIX_DEST=$RPM_BUILD_ROOT install
67
68 mv $RPM_BUILD_ROOT%{_docdir}/nsis $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
69
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74
75 %files
76 %defattr(-,root,root)
77 %{_bindir}/*
78 %config(noreplace) %{_sysconfdir}/nsisconf.nsh
79 %{_includedir}/nsis
80 %doc %{_docdir}/%{name}-%{version}
81 %{_datadir}/nsis
82
83
84 %changelog
85 * Tue Oct  7 2008 Richard W.M. Jones <rjones@redhat.com> - 2.39-2
86 - Initial RPM release.