Bump all spec releases for mass rebuild to mingw32-gcc 4.4
[fedora-mingw.git] / nsis / mingw32-nsis.spec
1 %define sconsopts VERSION=%{version} PREFIX=%{_prefix} PREFIX_CONF=%{_sysconfdir} SKIPPLUGINS=System DEBUG_SYMBOLS=1 OPTS=1
2 %define _default_patch_fuzz 2
3
4 Name:           mingw32-nsis
5 Version:        2.43
6 Release:        2%{?dist}
7 Summary:        Nullsoft Scriptable Install System
8
9 License:        zlib and CPL
10 Group:          Development/Libraries
11 URL:            http://nsis.sourceforge.net/
12 Source0:        http://dl.sourceforge.net/sourceforge/nsis/nsis-%{version}-src.tar.bz2
13 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
14
15 # Patches from Debian (mainly by Paul Wise).
16 Patch0:         nsis-2.42-debian-64bit-fixes.patch
17 Patch1:         nsis-2.43-debian-debug-opt.patch
18
19 BuildRequires:  mingw32-filesystem >= 40
20 BuildRequires:  mingw32-gcc
21 BuildRequires:  mingw32-gcc-c++
22 BuildRequires:  mingw32-binutils
23 BuildRequires:  python
24 BuildRequires:  scons
25
26 # since nsis a 32 bit only apps
27 #ExclusiveArch:  %{ix86} ppc
28 #BuildRequires:  wxGTK-devel
29 # The above is only required for Koji.  In mock we _can_ build on
30 # x86_64 provided we have the 32 bit libraries required by the next
31 # two lines.
32 BuildRequires:  /usr/include/gnu/stubs-32.h
33 BuildRequires:  /usr/lib/libwx_baseu-2.8.so
34
35
36 %description
37 NSIS, the Nullsoft Scriptable Install System, is a script-driven
38 Windows installation system.
39
40 This package includes native Fedora binaries of makensis (etc.) and
41 all plugins except for System.dll.  The System.dll plugin cannot be
42 built natively at this time since it includes inline Microsoft
43 assembler code.
44
45
46 %prep
47 %setup -q -n nsis-%{version}-src
48
49 %patch0 -p1 -b .64bit
50 %patch1 -p1 -b .debug
51
52
53 %build
54 scons %{sconsopts}
55
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 mkdir $RPM_BUILD_ROOT
61 scons %{sconsopts} PREFIX_DEST=$RPM_BUILD_ROOT install
62
63 mv $RPM_BUILD_ROOT%{_docdir}/nsis $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
64
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69
70 %files
71 %defattr(-,root,root)
72 %doc %{_docdir}/%{name}-%{version}
73 %config(noreplace) %{_sysconfdir}/nsisconf.nsh
74 %{_bindir}/*
75 #{_includedir}/nsis
76 %{_datadir}/nsis
77
78
79 %changelog
80 * Fri Feb 20 2009 Richard W.M. Jones <rjones@redhat.com> - 2.43-2
81 - Rebuild for mingw32-gcc 4.4
82
83 * Fri Feb 13 2009 Levente Farkas <lfarkas@lfarkas.org> - 2.43-1
84 - update to the latest upstream
85
86 * Wed Jan 14 2009 Levente Farkas <lfarkas@lfarkas.org> - 2.42-1
87 - update to the latest upstream
88 - a few small changes
89
90 * Fri Oct 17 2008 Richard W.M. Jones <rjones@redhat.com> - 2.39-5
91 - Fix the Summary line.
92
93 * Wed Oct  8 2008 Richard W.M. Jones <rjones@redhat.com> - 2.39-4
94 - Initial RPM release.