Don't limit uploads.
[fedora-mingw.git] / nsis / mingw32-nsis.spec
1 %define sconsopts VERSION=%{version} PREFIX=%{_prefix} PREFIX_CONF=%{_sysconfdir} SKIPPLUGINS=System DEBUG_SYMBOLS=1 OPTS=1
2 %define _default_patch_fuzz 2
3
4 Name:           mingw32-nsis
5 Version:        2.39
6 Release:        5%{?dist}
7 Summary:        Nullsoft Scriptable Install System
8
9 License:        zlib and CPL
10 Group:          Development/Libraries
11 URL:            http://nsis.sourceforge.net/
12 Source0:        http://dl.sourceforge.net/sourceforge/nsis/nsis-%{version}-src.tar.bz2
13 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
14
15 # Patches from Debian (mainly by Paul Wise).
16 Patch0:         nsis-2.39-debian-64bit-fixes.patch
17 Patch1:         nsis-2.39-debian-debug-opt.patch
18
19 # This patch is required for NSIS to find the correct cross-compiler.
20 Patch100:       nsis-2.39-mingw32-search.patch
21
22 BuildRequires:  mingw32-filesystem >= 20
23 BuildRequires:  mingw32-gcc
24 BuildRequires:  mingw32-gcc-c++
25 BuildRequires:  mingw32-binutils
26 BuildRequires:  python
27 BuildRequires:  scons >= 0.96.93
28
29 # We build with 'gcc -m32' and that fails on 64 bit platforms when we
30 # include <gnu/stubs.h>.  On x86-64, this is provided by
31 # glibc-devel.i386.  Depend on the file explicitly, since only recent
32 # versions of RPM let you require a package by architecture.
33 BuildRequires:  /usr/include/gnu/stubs-32.h
34
35 # We really need the 32 bit version of this library.  The 64 bit
36 # version will definitely not work.  XXX Need to do the right thing on
37 # non-x86 architectures.
38 BuildRequires:  /usr/lib/libwx_baseu-2.8.so
39
40
41 %description
42 NSIS, the Nullsoft Scriptable Install System, is a script-driven
43 Windows installation system.
44
45 This package includes native Fedora binaries of makensis (etc.) and
46 all plugins except for System.dll.  The System.dll plugin cannot be
47 built natively at this time since it includes inline Microsoft
48 assembler code.
49
50
51 %prep
52 %setup -q -n nsis-%{version}-src
53
54 %patch0 -p1
55 %patch1 -p1
56
57 %patch100 -p1
58
59
60 %build
61 scons %{sconsopts}
62
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66
67 mkdir $RPM_BUILD_ROOT
68 scons %{sconsopts} PREFIX_DEST=$RPM_BUILD_ROOT install
69
70 mv $RPM_BUILD_ROOT%{_docdir}/nsis $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
71
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76
77 %files
78 %defattr(-,root,root)
79 %{_bindir}/*
80 %config(noreplace) %{_sysconfdir}/nsisconf.nsh
81 %{_includedir}/nsis
82 %doc %{_docdir}/%{name}-%{version}
83 %{_datadir}/nsis
84
85
86 %changelog
87 * Fri Oct 17 2008 Richard W.M. Jones <rjones@redhat.com> - 2.39-5
88 - Fix the Summary line.
89
90 * Wed Oct  8 2008 Richard W.M. Jones <rjones@redhat.com> - 2.39-4
91 - Initial RPM release.