New version of libvirt.
[fedora-mingw.git] / nsis / mingw32-nsis.spec
1 %define sconsopts VERSION=%{version} PREFIX=%{_prefix} PREFIX_CONF=%{_sysconfdir} SKIPPLUGINS=System DEBUG_SYMBOLS=1 OPTS=1
2
3 Name:           mingw32-nsis
4 Version:        2.39
5 Release:        1%{?dist}
6 Summary:        MinGW Windows libxml2 XML processing library
7
8 License:        zlib and CPL
9 Group:          Development/Libraries
10 URL:            http://nsis.sourceforge.net/
11 Source0:        http://dl.sourceforge.net/sourceforge/nsis/nsis-%{version}-src.tar.bz2
12 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
13
14 # Patches from Debian (mainly by Paul Wise).
15 Patch0:         nsis-2.39-debian-64bit-fixes.patch
16 Patch1:         nsis-2.39-debian-debug-opt.patch
17
18 # This patch is required for NSIS to find the correct cross-compiler.
19 Patch2:         nsis-2.39-mingw32-search.patch
20
21 BuildRequires:  mingw32-filesystem >= 20
22 BuildRequires:  mingw32-gcc
23 BuildRequires:  mingw32-binutils
24 BuildRequires:  python
25 BuildRequires:  scons >= 0.96.93
26 BuildRequires:  wxGTK-devel
27
28
29 %description
30 NSIS, the Nullsoft Scriptable Install System, is a script-driven
31 Windows installation system.
32
33 This package includes native Fedora binaries of makensis (etc.) and
34 all plugins except for System.dll.  The System.dll plugin cannot be
35 built natively at this time since it includes inline Microsoft
36 assembler code.
37
38
39 %prep
40 %setup -q -n nsis-%{version}-src
41 %patch0 -p1
42 %patch1 -p1
43 %patch2 -p1
44
45
46 %build
47 scons %{sconsopts}
48
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 mkdir $RPM_BUILD_ROOT
54 scons %{sconsopts} PREFIX_DEST=$RPM_BUILD_ROOT install
55
56 mv $RPM_BUILD_ROOT%{_docdir}/nsis $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
57
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62
63 %files
64 %defattr(-,root,root)
65 %{_bindir}/*
66 %config(noreplace) %{_sysconfdir}/nsisconf.nsh
67 %{_includedir}/nsis
68 %doc %{_docdir}/%{name}-%{version}
69
70
71 %changelog
72 * Mon Sep 22 2008 Richard W.M. Jones <rjones@redhat.com> - 2.39-1
73 - Initial RPM release.