Very preliminary NSIS patch.
[fedora-mingw.git] / nsis / mingw-nsis.spec
1 Name:           mingw-nsis
2 Version:        2.39
3 Release:        1%{?dist}
4 Summary:        MinGW Windows libxml2 XML processing library
5
6 License:        zlib and CPL
7 Group:          Development/Libraries
8 URL:            http://nsis.sourceforge.net/
9 Source0:        http://dl.sourceforge.net/sourceforge/nsis/nsis-%{version}-src.tar.bz2
10 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
11
12 Patch0:         nsis-2.39-mingw-search.patch
13
14 BuildRequires:  mingw-filesystem >= 20
15 BuildRequires:  mingw-gcc
16 BuildRequires:  mingw-binutils
17 BuildRequires:  python
18 BuildRequires:  scons >= 0.96.93
19 BuildRequires:  wxGTK-devel
20
21
22 %description
23 NSIS, the Nullsoft Scriptable Install System, is a script-driven
24 Windows installation system.
25
26 This package includes native Fedora binaries of makensis (etc.)  There
27 are no native NSIS plugins available.  Complete Windows binaries and
28 plugins are in the mingw-nsis-win package, but you must run those
29 either on a Windows machine or under Wine.
30
31
32 %package win
33 Summary:        Windows binaries for %{name}
34 Requires:       %{name} = %{version}-%{release}
35 Group:          Development/Libraries
36
37 BuildArch:      noarch
38
39
40 %description win
41 This package includes complete Windows binaries and plugins for
42 %{name}.
43
44
45 %prep
46 %setup -q -n nsis-%{version}-src
47 %patch0 -p1
48
49
50 %build
51 scons \
52   PREFIX=%{_prefix} PREFIX_CONF=%{_sysconfdir}
53
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57
58 mkdir $RPM_BUILD_ROOT
59 scons \
60   PREFIX=%{_prefix} PREFIX_CONF=%{_sysconfdir} \
61   PREFIX_DEST=$RPM_BUILD_ROOT \
62   install
63
64 mv $RPM_BUILD_ROOT%{_docdir}/nsis $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
65
66 # It's not clear if we should move the Windows binaries
67 # to %{_mingw_sysroot} or leave them where they are.
68
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73
74 %files
75 %defattr(-,root,root)
76 %{_bindir}/*
77 %config(noreplace) %{_sysconfdir}/nsisconf.nsh
78 %{_includedir}/nsis
79 %doc %{_docdir}/%{name}-%{version}
80
81 %files win
82 %defattr(-,root,root)
83 %{_datadir}/nsis
84
85
86 %changelog
87 * Fri Sep  5 2008 Richard W.M. Jones <rjones@redhat.com> - 2.39-1
88 - Initial RPM release.