smock: Document how to use it without httpd
[fedora-mingw.git] / mingw64-runtime / mingw64-runtime.spec
1 %define __strip %{_mingw64_strip}
2 %define __objdump %{_mingw64_objdump}
3 %define _use_internal_dependency_generator 0
4 %define __find_requires %{_mingw64_findrequires}
5 %define __find_provides %{_mingw64_findprovides}
6
7 # SVN repo: https://mingw-w64.svn.sourceforge.net/svnroot/mingw-w64
8 # svn co https://....
9 # tar zcf mingw-w64-headers-%{svn_revision}.tar.gz \
10 #   mingw-w64/trunk/mingw-w64-headers
11 %define svn_revision 607
12
13 Name:           mingw64-runtime
14 Version:        0.1
15 Release:        0.svn%{svn_revision}.3%{?dist}
16 Summary:        MinGW Windows cross-compiler runtime
17
18 License:        Public Domain
19 Group:          Development/Libraries
20 URL:            http://mingw-w64.sourceforge.net/
21 Source0:        mingw-w64-crt-%{svn_revision}.tar.gz
22 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
23
24 BuildArch:      noarch
25
26 BuildRequires:  mingw64-filesystem >= 10
27 BuildRequires:  mingw64-binutils
28 BuildRequires:  mingw64-headers
29 BuildRequires:  mingw64-gcc-bootstrap
30
31
32 %description
33 MinGW Windows cross-compiler runtime, base libraries.
34
35
36 %prep
37 %setup -q -n mingw-w64
38
39
40 %build
41 pushd trunk/mingw-w64-crt
42 %{_mingw64_configure} --with-sysroot=%{_mingw64_sysroot}
43 make %{?_smp_mflags}
44 popd
45
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 pushd trunk/mingw-w64-crt
51 make DESTDIR=$RPM_BUILD_ROOT install
52 popd
53
54 # The above installs in /usr/x86_64-pc-mingw32/sys-root/x86_64-pc-mingw32/lib
55 # which is the wrong location.  Move it to %{_mingw64_libdir}.
56 mv $RPM_BUILD_ROOT%{_mingw64_sysroot}/%{_mingw64_target}/lib \
57   $RPM_BUILD_ROOT%{_mingw64_libdir}
58
59 # However GCC when building looks in /usr/x86_64-pc-mingw32/lib for
60 # libraries.  Make symlinks so that this works.
61 # XXX Hack - why is this needed?
62 mkdir -p $RPM_BUILD_ROOT%{_prefix}/%{_mingw64_target}/lib
63 pushd $RPM_BUILD_ROOT%{_prefix}/%{_mingw64_target}/lib
64 for f in ../sys-root/lib/*.[ao]; do
65   ln -s $f
66 done
67 popd
68
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73
74 %files
75 %defattr(-,root,root)
76 %{_mingw64_libdir}/*
77 %{_prefix}/%{_mingw64_target}/lib/*
78
79
80 %changelog
81 * Wed Feb 11 2009 Richard W.M. Jones <rjones@redhat.com> - 0.1-0.svn607.3
82 - Started mingw64 development.
83
84 * Tue Feb 10 2009 Richard W.M. Jones <rjones@redhat.com> - 3.15.2-1
85 - New upstream release 3.15.2.
86
87 * Tue Dec  9 2008 Richard W.M. Jones <rjones@redhat.com> - 3.15.1-10
88 - Force rebuild to get rid of the binary bootstrap package and replace
89   with package built from source.
90
91 * Wed Nov 26 2008 Richard W.M. Jones <rjones@redhat.com> - 3.15.1-9
92 - No runtime dependency on binutils or gcc.
93 - But it DOES BR w32api.
94
95 * Mon Nov 24 2008 Richard W.M. Jones <rjones@redhat.com> - 3.15.1-8
96 - Rebuild against latest filesystem package.
97 - MINGW_CFLAGS -> MINGW32_CFLAGS.
98 - Rewrite the summary for accuracy and brevity.
99
100 * Fri Nov 21 2008 Richard W.M. Jones <rjones@redhat.com> - 3.15.1-6
101 - Remove obsoletes for a long dead package.
102 - Reenable (and fix) _mingw32_configure (Levente Farkas).
103
104 * Thu Nov 20 2008 Richard W.M. Jones <rjones@redhat.com> - 3.15.1-5
105 - Don't use _mingw32_configure macro - doesn't work here.
106
107 * Wed Nov 19 2008 Richard W.M. Jones <rjones@redhat.com> - 3.15.1-4
108 - Rebuild against mingw32-filesystem 37
109
110 * Wed Nov 19 2008 Richard W.M. Jones <rjones@redhat.com> - 3.15.1-3
111 - Remove the useconds patch, which is no longer needed (Levente Farkas).
112 - Use _mingw32_configure macro.
113
114 * Wed Nov 19 2008 Richard W.M. Jones <rjones@redhat.com> - 3.15.1-2
115 - Rebuild against mingw32-filesystem 36
116
117 * Thu Oct 16 2008 Richard W.M. Jones <rjones@redhat.com> - 3.15.1-1
118 - New upstream version 3.15.1.
119
120 * Wed Sep 24 2008 Richard W.M. Jones <rjones@redhat.com> - 3.14-6
121 - Rename mingw -> mingw32.
122
123 * Thu Sep  4 2008 Richard W.M. Jones <rjones@redhat.com> - 3.14-4
124 - Use RPM macros from mingw-filesystem.
125
126 * Mon Jul  7 2008 Richard W.M. Jones <rjones@redhat.com> - 3.14-2
127 - Initial RPM release, largely based on earlier work from several sources.