Bump all spec releases for mass rebuild to mingw32-gcc 4.4
[fedora-mingw.git] / libxslt / mingw32-libxslt.spec
1 %define __strip %{_mingw32_strip}
2 %define __objdump %{_mingw32_objdump}
3 %define _use_internal_dependency_generator 0
4 %define __find_requires %{_mingw32_findrequires}
5 %define __find_provides %{_mingw32_findprovides}
6
7 Name:           mingw32-libxslt
8 Version:        1.1.24
9 Release:        5%{?dist}
10 Summary:        MinGW Windows Library providing the Gnome XSLT engine
11
12 License:        MIT
13 Group:          Development/Libraries
14 URL:            http://xmlsoft.org/XSLT/
15 Source0:        ftp://xmlsoft.org/XSLT/libxslt-%{version}.tar.gz
16 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17
18 BuildArch:      noarch
19
20 Patch0:         multilib.patch
21 Patch1:         libexslt-rc4.patch
22
23 Patch1000:      mingw32-libxslt-1.1.24-win32-shared.patch
24
25 BuildRequires:  mingw32-filesystem >= 30
26 BuildRequires:  mingw32-gcc
27 BuildRequires:  mingw32-binutils
28 BuildRequires:  mingw32-dlfcn
29 BuildRequires:  mingw32-iconv
30 BuildRequires:  mingw32-libgcrypt
31 BuildRequires:  mingw32-libxml2 >= 2.7.2-3
32 BuildRequires:  pkgconfig
33 BuildRequires:  autoconf, automake, libtool
34
35 Requires:       mingw32-libxml2 >= 2.7.2-3
36 Requires:       pkgconfig
37
38
39 %description
40 This C library allows to transform XML files into other XML files
41 (or HTML, text, ...) using the standard XSLT stylesheet transformation
42 mechanism. To use it you need to have a version of libxml2 >= 2.6.27
43 installed. The xsltproc command is a command line interface to the XSLT engine
44
45
46 %prep
47 %setup -q -n libxslt-%{version}
48 %patch0 -p1
49 %patch1 -p0
50
51 %patch1000 -p1
52
53 libtoolize --force --copy
54 autoreconf
55
56
57 %build
58 PATH=%{_mingw32_bindir}:$PATH \
59 %{_mingw32_configure} --without-python --enable-shared
60 make %{?_smp_mflags}
61 gzip -9 ChangeLog
62
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66 make DESTDIR=$RPM_BUILD_ROOT install
67
68 # Remove static libraries but DON'T remove *.dll.a files.
69 # Note that ./configure --disable-static doesn't work.
70 rm $RPM_BUILD_ROOT%{_mingw32_libdir}/libexslt.a
71 rm $RPM_BUILD_ROOT%{_mingw32_libdir}/libxslt.a
72
73 # Remove doc and man which duplicate stuff already in Fedora native package.
74 rm -r $RPM_BUILD_ROOT%{_mingw32_docdir}
75 rm -r $RPM_BUILD_ROOT%{_mingw32_mandir}
76
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81
82 %files
83 %defattr(-,root,root)
84 %doc COPYING
85 %{_mingw32_bindir}/xslt-config
86 %{_mingw32_bindir}/xsltproc.exe
87 %{_mingw32_includedir}/libexslt
88 %{_mingw32_includedir}/libxslt
89 #%{_mingw32_bindir}/libexslt.dll
90 #%{_mingw32_libdir}/libexslt.dll.a
91 %{_mingw32_libdir}/libexslt.la
92 %{_mingw32_bindir}/libxslt-1.dll
93 %{_mingw32_libdir}/libxslt.dll.a
94 %{_mingw32_libdir}/libxslt.la
95 %{_mingw32_libdir}/pkgconfig/libexslt.pc
96 %{_mingw32_libdir}/pkgconfig/libxslt.pc
97 %{_mingw32_libdir}/xsltConf.sh
98 %{_mingw32_datadir}/aclocal/libxslt.m4
99
100
101 %changelog
102 * Fri Feb 20 2009 Richard W.M. Jones <rjones@redhat.com> - 1.1.24-5
103 - Rebuild for mingw32-gcc 4.4
104
105 * Fri Feb  6 2009 Richard W.M. Jones <rjones@redhat.com> - 1.1.24-4
106 - Include license file.
107
108 * Fri Jan 23 2009 Richard W.M. Jones <rjones@redhat.com> - 1.1.24-3
109 - Use _smp_mflags.
110 - Rebuild libtool.
111 - +BRs dlfcn and iconv.
112
113 * Sat Oct 25 2008 Richard W.M. Jones <rjones@redhat.com> - 1.1.24-2
114 - Initial RPM release.