configure --disable-static didn't work.
[fedora-mingw.git] / libxslt / mingw32-libxslt.spec
1 %define __strip %{_mingw32_strip}
2 %define __objdump %{_mingw32_objdump}
3 %define _use_internal_dependency_generator 0
4 %define __find_requires %{_mingw32_findrequires}
5 %define __find_provides %{_mingw32_findprovides}
6
7 Name:           mingw32-libxslt
8 Version:        1.1.24
9 Release:        3%{?dist}
10 Summary:        MinGW Windows Library providing the Gnome XSLT engine
11
12 License:        MIT
13 Group:          Development/Libraries
14 URL:            http://xmlsoft.org/XSLT/
15 Source0:        ftp://xmlsoft.org/XSLT/libxslt-%{version}.tar.gz
16 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17
18 BuildArch:      noarch
19
20 Patch0:         multilib.patch
21 Patch1:         libexslt-rc4.patch
22
23 Patch1000:      mingw32-libxslt-1.1.24-win32-shared.patch
24
25 BuildRequires:  mingw32-filesystem >= 30
26 BuildRequires:  mingw32-gcc
27 BuildRequires:  mingw32-binutils
28 BuildRequires:  mingw32-libgcrypt
29 BuildRequires:  mingw32-libxml2 >= 2.7.2-3
30 BuildRequires:  pkgconfig
31 BuildRequires:  autoconf, automake, libtool
32
33 Requires:       mingw32-libxml2 >= 2.7.2-3
34 Requires:       pkgconfig
35
36
37 %description
38 This C library allows to transform XML files into other XML files
39 (or HTML, text, ...) using the standard XSLT stylesheet transformation
40 mechanism. To use it you need to have a version of libxml2 >= 2.6.27
41 installed. The xsltproc command is a command line interface to the XSLT engine
42
43
44 %prep
45 %setup -q -n libxslt-%{version}
46 %patch0 -p1
47 %patch1 -p0
48
49 %patch1000 -p1
50
51
52 %build
53 PATH=%{_mingw32_bindir}:$PATH \
54 %{_mingw32_configure} --without-python --enable-shared
55 make %{?_smp_mflags}
56 gzip -9 ChangeLog
57
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61 make DESTDIR=$RPM_BUILD_ROOT install
62
63 # Remove static libraries but DON'T remove *.dll.a files.
64 # Note that ./configure --disable-static doesn't work.
65 rm $RPM_BUILD_ROOT%{_mingw32_libdir}/libexslt.a
66 rm $RPM_BUILD_ROOT%{_mingw32_libdir}/libxslt.a
67
68 # Remove doc and man which duplicate stuff already in Fedora native package.
69 rm -r $RPM_BUILD_ROOT%{_mingw32_docdir}
70 rm -r $RPM_BUILD_ROOT%{_mingw32_mandir}
71
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76
77 %files
78 %defattr(-,root,root)
79 %{_mingw32_bindir}/xslt-config
80 %{_mingw32_bindir}/xsltproc.exe
81 %{_mingw32_includedir}/libexslt
82 %{_mingw32_includedir}/libxslt
83 #%{_mingw32_bindir}/libexslt.dll
84 #%{_mingw32_libdir}/libexslt.dll.a
85 %{_mingw32_libdir}/libexslt.la
86 %{_mingw32_bindir}/libxslt-1.dll
87 %{_mingw32_libdir}/libxslt.dll.a
88 %{_mingw32_libdir}/libxslt.la
89 %{_mingw32_libdir}/pkgconfig/libexslt.pc
90 %{_mingw32_libdir}/pkgconfig/libxslt.pc
91 %{_mingw32_libdir}/xsltConf.sh
92 %{_mingw32_datadir}/aclocal/libxslt.m4
93
94
95 %changelog
96 * Fri Jan 23 2009 Richard W.M. Jones <rjones@redhat.com> - 1.1.24-3
97 - Use _smp_mflags.
98
99 * Sat Oct 25 2008 Richard W.M. Jones <rjones@redhat.com> - 1.1.24-2
100 - Initial RPM release.