- Resynch with Fedora package (0.13.2).
[fedora-mingw.git] / libxml2 / mingw32-libxml2.spec
1 %define __strip %{_mingw32_strip}
2 %define __objdump %{_mingw32_objdump}
3 %define _use_internal_dependency_generator 0
4 %define __find_requires %{_mingw32_findrequires}
5 %define __find_provides %{_mingw32_findprovides}
6
7 Name:           mingw32-libxml2
8 Version:        2.7.2
9 Release:        3%{?dist}
10 Summary:        MinGW Windows libxml2 XML processing library
11
12 License:        MIT
13 Group:          Development/Libraries
14 URL:            http://xmlsoft.org/
15 Source0:        ftp://xmlsoft.org/libxml2/libxml2-%{version}.tar.gz
16 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17
18 # Not required for MinGW.
19 #Patch0:         libxml2-multilib.patch
20
21 # MinGW-specific patches.
22 Patch1000:      mingw32-libxml2-2.7.2-with-modules.patch
23
24 BuildArch:      noarch
25
26 BuildRequires:  mingw32-filesystem >= 23
27 BuildRequires:  mingw32-gcc
28 BuildRequires:  mingw32-binutils
29 BuildRequires:  mingw32-zlib
30 BuildRequires:  mingw32-gettext
31
32
33 %description
34 MinGW Windows libxml2 XML processing library.
35
36
37 %prep
38 %setup -q -n libxml2-%{version}
39 %patch1000 -p1
40
41
42 %build
43 LDFLAGS="-no-undefined" %{_mingw32_configure} --without-python --with-modules
44 make
45
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 make DESTDIR=$RPM_BUILD_ROOT install
51
52 rm $RPM_BUILD_ROOT%{_mingw32_libdir}/libxml2.a
53
54 # Remove manpages which duplicate Fedora native.
55 rm -rf $RPM_BUILD_ROOT%{_mingw32_mandir}
56
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61
62 %files
63 %defattr(-,root,root)
64 %{_mingw32_bindir}/libxml2-2.dll
65 %{_mingw32_bindir}/xml2-config
66 %{_mingw32_bindir}/xmlcatalog.exe
67 %{_mingw32_bindir}/xmllint.exe
68 %{_mingw32_libdir}/libxml2.dll.a
69 %{_mingw32_libdir}/libxml2.la
70 %{_mingw32_libdir}/pkgconfig
71 %{_mingw32_libdir}/pkgconfig/libxml-2.0.pc
72 %{_mingw32_libdir}/xml2Conf.sh
73 %{_mingw32_includedir}/libxml2
74 %{_mingw32_datadir}/aclocal/*
75 %{_mingw32_docdir}/libxml2-%{version}/
76 %{_mingw32_datadir}/gtk-doc/html/libxml2/
77
78
79 %changelog
80 * Sat Oct 25 2008 Richard W.M. Jones <rjones@redhat.com> - 2.7.2-3
81 - Enable modules support for libxslt.
82
83 * Fri Oct 17 2008 Richard W.M. Jones <rjones@redhat.com> - 2.7.2-1
84 - Resynch to native Fedora package + patch.
85
86 * Wed Sep 24 2008 Richard W.M. Jones <rjones@redhat.com> - 2.7.1-2
87 - Rename mingw -> mingw32.
88
89 * Mon Sep 22 2008 Daniel P. Berrange <berrange@redhat.com> - 2.7.1-1
90 - Update to 2.7.1 release
91
92 * Sun Sep 21 2008 Richard W.M. Jones <rjones@redhat.com> - 2.6.32-5
93 - Remove manpages which duplicate Fedora native.
94
95 * Wed Sep 10 2008 Richard W.M. Jones <rjones@redhat.com> - 2.6.32-4
96 - Remove static libraries.
97 - List libdir files explicitly.
98
99 * Fri Sep  5 2008 Richard W.M. Jones <rjones@redhat.com> - 2.6.32-3
100 - Use RPM macros from mingw-filesystem.
101 - BuildArch is noarch.
102
103 * Mon Jul  7 2008 Richard W.M. Jones <rjones@redhat.com> - 2.6.32-1
104 - Initial RPM release, largely based on earlier work from several sources.