- Rebase to Fedora native version 0.5.1.
[fedora-mingw.git] / libvirt / mingw32-libvirt.spec
1 %define __strip %{_mingw32_strip}
2 %define __objdump %{_mingw32_objdump}
3 %define _use_internal_dependency_generator 0
4 %define __find_requires %{_mingw32_findrequires}
5 %define __find_provides %{_mingw32_findprovides}
6
7 Name:           mingw32-libvirt
8 Version:        0.5.1
9 Release:        1%{?dist}%{?extra_release}
10 Summary:        MinGW Windows libvirt virtualization library
11
12 License:        LGPLv2+
13 Group:          Development/Libraries
14 URL:            http://libvirt.org/
15 Source0:        ftp://libvirt.org/libvirt/libvirt-%{version}.tar.gz
16 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17
18 BuildRequires:  mingw32-filesystem >= 23
19 BuildRequires:  mingw32-gcc
20 BuildRequires:  mingw32-binutils
21 BuildRequires:  mingw32-libgpg-error
22 BuildRequires:  mingw32-libgcrypt
23 BuildRequires:  mingw32-gnutls
24 BuildRequires:  mingw32-gettext
25 BuildRequires:  mingw32-libxml2
26 # Portable XDR <= 4.0.10 contains a serious endianness bug on Windows.
27 BuildRequires:  mingw32-portablexdr >= 4.0.11
28 BuildRequires:  mingw32-readline
29 BuildRequires:  mingw32-termcap >= 1.3.1-3
30 BuildRequires:  pkgconfig
31
32 # Need native version for msgfmt
33 BuildRequires:  gettext
34
35 BuildArch:      noarch
36
37
38 %description
39 MinGW Windows libvirt virtualization library.
40
41
42 %prep
43 %setup -q -n libvirt-%{version}
44
45
46 %build
47 # XXX enable SASL in future
48 %{_mingw32_configure} \
49   --without-sasl \
50   --without-avahi \
51   --without-polkit \
52   --without-python \
53   --without-xen \
54   --without-qemu \
55   --without-lxc \
56   --without-openvz \
57   --without-uml \
58   --without-libvirtd \
59   --disable-static
60 make %{?_smp_mflags}
61
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65
66 make DESTDIR=$RPM_BUILD_ROOT install
67
68 rm -rf $RPM_BUILD_ROOT%{_mingw32_sysconfdir}/libvirt
69 rm -rf $RPM_BUILD_ROOT%{_mingw32_datadir}/doc/*
70 rm -rf $RPM_BUILD_ROOT%{_mingw32_datadir}/gtk-doc/*
71
72 %find_lang libvirt
73
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78
79 %files -f libvirt.lang
80 %defattr(-,root,root)
81 %{_mingw32_bindir}/libvirt-0.dll
82 %{_mingw32_bindir}/virsh.exe
83
84 %{_mingw32_libdir}/libvirt.dll.a
85 %{_mingw32_libdir}/libvirt.la
86 %{_mingw32_libdir}/pkgconfig/libvirt.pc
87
88 %dir %{_mingw32_includedir}/libvirt
89 %{_mingw32_includedir}/libvirt/libvirt.h
90 %{_mingw32_includedir}/libvirt/virterror.h
91
92 %{_mingw32_mandir}/man1/virsh.1*
93
94
95 %changelog
96 * Fri Jan 23 2009 Richard Jones <rjones@redhat.com> - 0.5.1-1
97 - Rebase to Fedora native version 0.5.1.
98 - Use find_lang macro.
99 - Use _smp_mflags.
100 - Disable static libraries.
101
102 * Wed Nov 26 2008 Richard Jones <rjones@redhat.com> - 0.5.0-1
103 - New upstream version 0.5.0.
104
105 * Sat Nov 22 2008 Richard Jones <rjones@redhat.com> - 0.4.6-9
106 - Rebuild against new readline.
107
108 * Fri Oct 31 2008 Richard Jones <rjones@redhat.com> - 0.4.6-8
109 - Rebuild against latest termcap.
110
111 * Thu Oct 16 2008 Richard Jones <rjones@redhat.com> - 0.4.6-7
112 - Windows icon patch from
113   https://www.redhat.com/archives/libvir-list/2008-October/msg00331.html
114
115 * Wed Oct 15 2008 Richard Jones <rjones@redhat.com> - 0.4.6-6
116 - Add patches from
117   https://www.redhat.com/archives/libvir-list/2008-October/msg00328.html
118 - BR mingw32-portablexdr >= 4.0.11 to fix serious Windows endianness bug.
119
120 * Tue Oct 14 2008 Richard Jones <rjones@redhat.com> - 0.4.6-4
121 - +BR mingw32-readline.
122
123 * Thu Sep 25 2008 Richard Jones <rjones@redhat.com> - 0.4.6-3
124 - BuildArch should be noarch
125
126 * Wed Sep 24 2008 Richard W.M. Jones <rjones@redhat.com> - 0.4.6-2
127 - Whitespace removal.
128
129 * Wed Sep 24 2008 Richard W.M. Jones <rjones@redhat.com> - 0.4.6-1
130 - New upstream release 0.4.6.
131 - Rename mingw -> mingw32.
132
133 * Mon Sep 22 2008 Daniel P. Berrange <berrange@redhat.com> - 0.4.5-4%{?extra_release}
134 - Import crash fix from rawhide
135
136 * Thu Sep 11 2008 Daniel P. Berrange <berrange@redhat.com> - 0.4.5-3%{?extra_release}
137 - Add dep on gettext & pkgconfig
138
139 * Wed Sep 10 2008 Richard W.M. Jones <rjones@redhat.com> - 0.4.5-2
140 - Remove static lib.
141
142 * Tue Sep  2 2008 Daniel P. Berrange <berrange@redhat.com> - 0.4.4-1
143 - Initial RPM release, largely based on earlier work from several sources.