Rebuild against new OpenSSH (because of soname bump).
[fedora-mingw.git] / libvirt / mingw32-libvirt.spec
1 %define __strip %{_mingw32_strip}
2 %define __objdump %{_mingw32_objdump}
3 %define _use_internal_dependency_generator 0
4 %define __find_requires %{_mingw32_findrequires}
5 %define __find_provides %{_mingw32_findprovides}
6
7 Name:           mingw32-libvirt
8 Version:        0.5.1
9 Release:        2%{?dist}%{?extra_release}
10 Summary:        MinGW Windows libvirt virtualization library
11
12 License:        LGPLv2+
13 Group:          Development/Libraries
14 URL:            http://libvirt.org/
15 Source0:        ftp://libvirt.org/libvirt/libvirt-%{version}.tar.gz
16 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17
18 BuildRequires:  mingw32-filesystem >= 23
19 BuildRequires:  mingw32-gcc
20 BuildRequires:  mingw32-binutils
21 BuildRequires:  mingw32-libgpg-error
22 BuildRequires:  mingw32-libgcrypt
23 BuildRequires:  mingw32-gnutls
24 BuildRequires:  mingw32-gettext
25 BuildRequires:  mingw32-libxml2
26 # Portable XDR <= 4.0.10 contains a serious endianness bug on Windows.
27 BuildRequires:  mingw32-portablexdr >= 4.0.11
28 BuildRequires:  mingw32-readline
29 BuildRequires:  mingw32-termcap >= 1.3.1-3
30 BuildRequires:  pkgconfig
31
32 # Need native version for msgfmt
33 BuildRequires:  gettext
34
35 BuildArch:      noarch
36
37 Requires:       pkgconfig
38
39
40 %description
41 MinGW Windows libvirt virtualization library.
42
43
44 %prep
45 %setup -q -n libvirt-%{version}
46
47
48 %build
49 # XXX enable SASL in future
50 %{_mingw32_configure} \
51   --without-sasl \
52   --without-avahi \
53   --without-polkit \
54   --without-python \
55   --without-xen \
56   --without-qemu \
57   --without-lxc \
58   --without-openvz \
59   --without-uml \
60   --without-libvirtd \
61   --disable-static
62 make %{?_smp_mflags}
63
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67
68 make DESTDIR=$RPM_BUILD_ROOT install
69
70 rm -rf $RPM_BUILD_ROOT%{_mingw32_sysconfdir}/libvirt
71 rm -rf $RPM_BUILD_ROOT%{_mingw32_datadir}/doc/*
72 rm -rf $RPM_BUILD_ROOT%{_mingw32_datadir}/gtk-doc/*
73
74 %find_lang libvirt
75
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80
81 %files -f libvirt.lang
82 %defattr(-,root,root)
83 %{_mingw32_bindir}/libvirt-0.dll
84 %{_mingw32_bindir}/virsh.exe
85
86 %{_mingw32_libdir}/libvirt.dll.a
87 %{_mingw32_libdir}/libvirt.la
88 %{_mingw32_libdir}/pkgconfig/libvirt.pc
89
90 %dir %{_mingw32_includedir}/libvirt
91 %{_mingw32_includedir}/libvirt/libvirt.h
92 %{_mingw32_includedir}/libvirt/virterror.h
93
94 %{_mingw32_mandir}/man1/virsh.1*
95
96
97 %changelog
98 * Fri Jan 30 2009 Richard Jones <rjones@redhat.com> - 0.5.1-2
99 - Requires pkgconfig.
100
101 * Fri Jan 23 2009 Richard Jones <rjones@redhat.com> - 0.5.1-1
102 - Rebase to Fedora native version 0.5.1.
103 - Use find_lang macro.
104 - Use _smp_mflags.
105 - Disable static libraries.
106
107 * Wed Nov 26 2008 Richard Jones <rjones@redhat.com> - 0.5.0-1
108 - New upstream version 0.5.0.
109
110 * Sat Nov 22 2008 Richard Jones <rjones@redhat.com> - 0.4.6-9
111 - Rebuild against new readline.
112
113 * Fri Oct 31 2008 Richard Jones <rjones@redhat.com> - 0.4.6-8
114 - Rebuild against latest termcap.
115
116 * Thu Oct 16 2008 Richard Jones <rjones@redhat.com> - 0.4.6-7
117 - Windows icon patch from
118   https://www.redhat.com/archives/libvir-list/2008-October/msg00331.html
119
120 * Wed Oct 15 2008 Richard Jones <rjones@redhat.com> - 0.4.6-6
121 - Add patches from
122   https://www.redhat.com/archives/libvir-list/2008-October/msg00328.html
123 - BR mingw32-portablexdr >= 4.0.11 to fix serious Windows endianness bug.
124
125 * Tue Oct 14 2008 Richard Jones <rjones@redhat.com> - 0.4.6-4
126 - +BR mingw32-readline.
127
128 * Thu Sep 25 2008 Richard Jones <rjones@redhat.com> - 0.4.6-3
129 - BuildArch should be noarch
130
131 * Wed Sep 24 2008 Richard W.M. Jones <rjones@redhat.com> - 0.4.6-2
132 - Whitespace removal.
133
134 * Wed Sep 24 2008 Richard W.M. Jones <rjones@redhat.com> - 0.4.6-1
135 - New upstream release 0.4.6.
136 - Rename mingw -> mingw32.
137
138 * Mon Sep 22 2008 Daniel P. Berrange <berrange@redhat.com> - 0.4.5-4%{?extra_release}
139 - Import crash fix from rawhide
140
141 * Thu Sep 11 2008 Daniel P. Berrange <berrange@redhat.com> - 0.4.5-3%{?extra_release}
142 - Add dep on gettext & pkgconfig
143
144 * Wed Sep 10 2008 Richard W.M. Jones <rjones@redhat.com> - 0.4.5-2
145 - Remove static lib.
146
147 * Tue Sep  2 2008 Daniel P. Berrange <berrange@redhat.com> - 0.4.4-1
148 - Initial RPM release, largely based on earlier work from several sources.