42cfa5e4d9ccb475055fa03eaa69cca7aeb98900
[fedora-mingw.git] / libvirt / mingw32-libvirt.spec
1 %define __strip %{_mingw32_strip}
2 %define __objdump %{_mingw32_objdump}
3 %define _use_internal_dependency_generator 0
4 %define __find_requires %{_mingw32_findrequires}
5 %define __find_provides %{_mingw32_findprovides}
6
7 Name:           mingw32-libvirt
8 Version:        0.5.1
9 Release:        3%{?dist}%{?extra_release}
10 Summary:        MinGW Windows libvirt virtualization library
11
12 License:        LGPLv2+
13 Group:          Development/Libraries
14 URL:            http://libvirt.org/
15 Source0:        ftp://libvirt.org/libvirt/libvirt-%{version}.tar.gz
16 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17
18 BuildRequires:  mingw32-filesystem >= 23
19 BuildRequires:  mingw32-gcc
20 BuildRequires:  mingw32-binutils
21 BuildRequires:  mingw32-libgpg-error
22 BuildRequires:  mingw32-libgcrypt
23 BuildRequires:  mingw32-gnutls
24 BuildRequires:  mingw32-gettext
25 BuildRequires:  mingw32-libxml2
26 # Portable XDR <= 4.0.10 contains a serious endianness bug on Windows.
27 BuildRequires:  mingw32-portablexdr >= 4.0.11
28 BuildRequires:  mingw32-readline
29 BuildRequires:  mingw32-termcap >= 1.3.1-3
30 BuildRequires:  pkgconfig
31
32 # Need native version for msgfmt
33 BuildRequires:  gettext
34
35 BuildArch:      noarch
36
37 Requires:       pkgconfig
38
39
40 %description
41 MinGW Windows libvirt virtualization library.
42
43
44 %prep
45 %setup -q -n libvirt-%{version}
46
47
48 %build
49 # XXX enable SASL in future
50 %{_mingw32_configure} \
51   --without-sasl \
52   --without-avahi \
53   --without-polkit \
54   --without-python \
55   --without-xen \
56   --without-qemu \
57   --without-lxc \
58   --without-openvz \
59   --without-uml \
60   --without-libvirtd \
61   --disable-static
62 make %{?_smp_mflags}
63
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67
68 make DESTDIR=$RPM_BUILD_ROOT install
69
70 rm -rf $RPM_BUILD_ROOT%{_mingw32_sysconfdir}/libvirt
71 rm -rf $RPM_BUILD_ROOT%{_mingw32_datadir}/doc/*
72 rm -rf $RPM_BUILD_ROOT%{_mingw32_datadir}/gtk-doc/*
73
74 %find_lang libvirt
75
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80
81 %files -f libvirt.lang
82 %defattr(-,root,root)
83 %doc COPYING.LIB
84 %{_mingw32_bindir}/libvirt-0.dll
85 %{_mingw32_bindir}/virsh.exe
86
87 %{_mingw32_libdir}/libvirt.dll.a
88 %{_mingw32_libdir}/libvirt.la
89 %{_mingw32_libdir}/pkgconfig/libvirt.pc
90
91 %dir %{_mingw32_includedir}/libvirt
92 %{_mingw32_includedir}/libvirt/libvirt.h
93 %{_mingw32_includedir}/libvirt/virterror.h
94
95 %{_mingw32_mandir}/man1/virsh.1*
96
97
98 %changelog
99 * Fri Jan 30 2009 Richard Jones <rjones@redhat.com> - 0.5.1-3
100 - Include license file.
101
102 * Fri Jan 30 2009 Richard Jones <rjones@redhat.com> - 0.5.1-2
103 - Requires pkgconfig.
104
105 * Fri Jan 23 2009 Richard Jones <rjones@redhat.com> - 0.5.1-1
106 - Rebase to Fedora native version 0.5.1.
107 - Use find_lang macro.
108 - Use _smp_mflags.
109 - Disable static libraries.
110
111 * Wed Nov 26 2008 Richard Jones <rjones@redhat.com> - 0.5.0-1
112 - New upstream version 0.5.0.
113
114 * Sat Nov 22 2008 Richard Jones <rjones@redhat.com> - 0.4.6-9
115 - Rebuild against new readline.
116
117 * Fri Oct 31 2008 Richard Jones <rjones@redhat.com> - 0.4.6-8
118 - Rebuild against latest termcap.
119
120 * Thu Oct 16 2008 Richard Jones <rjones@redhat.com> - 0.4.6-7
121 - Windows icon patch from
122   https://www.redhat.com/archives/libvir-list/2008-October/msg00331.html
123
124 * Wed Oct 15 2008 Richard Jones <rjones@redhat.com> - 0.4.6-6
125 - Add patches from
126   https://www.redhat.com/archives/libvir-list/2008-October/msg00328.html
127 - BR mingw32-portablexdr >= 4.0.11 to fix serious Windows endianness bug.
128
129 * Tue Oct 14 2008 Richard Jones <rjones@redhat.com> - 0.4.6-4
130 - +BR mingw32-readline.
131
132 * Thu Sep 25 2008 Richard Jones <rjones@redhat.com> - 0.4.6-3
133 - BuildArch should be noarch
134
135 * Wed Sep 24 2008 Richard W.M. Jones <rjones@redhat.com> - 0.4.6-2
136 - Whitespace removal.
137
138 * Wed Sep 24 2008 Richard W.M. Jones <rjones@redhat.com> - 0.4.6-1
139 - New upstream release 0.4.6.
140 - Rename mingw -> mingw32.
141
142 * Mon Sep 22 2008 Daniel P. Berrange <berrange@redhat.com> - 0.4.5-4%{?extra_release}
143 - Import crash fix from rawhide
144
145 * Thu Sep 11 2008 Daniel P. Berrange <berrange@redhat.com> - 0.4.5-3%{?extra_release}
146 - Add dep on gettext & pkgconfig
147
148 * Wed Sep 10 2008 Richard W.M. Jones <rjones@redhat.com> - 0.4.5-2
149 - Remove static lib.
150
151 * Tue Sep  2 2008 Daniel P. Berrange <berrange@redhat.com> - 0.4.4-1
152 - Initial RPM release, largely based on earlier work from several sources.