d82903cd605960972518b7e41d373d66f6f36ccf
[fedora-mingw.git] / libsigc++20 / mingw32-libsigc++20.spec
1 %define __strip %{_mingw32_strip}
2 %define __objdump %{_mingw32_objdump}
3 %define _use_internal_dependency_generator 0
4 %define __find_requires %{_mingw32_findrequires}
5 %define __find_provides %{_mingw32_findprovides}
6
7 Name:           mingw32-libsigc++20
8 Version:        2.2.2
9 Release:        4%{?dist}
10 Summary:        MinGW Windows port of the typesafe signal framework for C++
11
12 License:        LGPLv2+
13 Group:          Development/Libraries
14 URL:            http://libsigc.sourceforge.net/
15 Source0:        http://ftp.gnome.org/pub/GNOME/sources/libsigc++/2.2/libsigc++-%{version}.tar.bz2
16 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17
18 BuildArch:      noarch
19
20 BuildRequires:  mingw32-filesystem >= 30
21 BuildRequires:  mingw32-gcc
22 BuildRequires:  mingw32-gcc-c++
23 BuildRequires:  mingw32-binutils
24
25 BuildRequires:  m4
26
27 Requires:       pkgconfig
28
29
30 %description
31 This library implements a full callback system for use in widget
32 libraries, abstract interfaces, and general programming. Originally
33 part of the Gtk-- widget set, %name is now a separate library to
34 provide for more general use. It is the most complete library of its
35 kind with the ability to connect an abstract callback to a class
36 method, function, or function object. It contains adaptor classes for
37 connection of dissimilar callbacks and has an ease of use unmatched by
38 other C++ callback libraries.
39
40 Package GTK-- (gtkmm), which is a C++ binding to the GTK+ library,
41 starting with version 1.1.2, uses %name.
42
43
44 %prep
45 %setup -q -n libsigc++-%{version}
46
47
48 %build
49 %{_mingw32_configure} --disable-static
50 make %{?_smp_mflags}
51
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55 make DESTDIR=$RPM_BUILD_ROOT install
56
57 # Docs duplicate native package.
58 rm -r $RPM_BUILD_ROOT%{_mingw32_docdir}/libsigc-2.0
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63
64 %files
65 %defattr(-,root,root)
66 %doc COPYING
67 %{_mingw32_bindir}/libsigc-2.0-0.dll
68 %{_mingw32_libdir}/libsigc-2.0.dll.a
69 %{_mingw32_libdir}/libsigc-2.0.la
70 %{_mingw32_libdir}/pkgconfig/sigc++-2.0.pc
71 %{_mingw32_includedir}/sigc++-2.0
72 # WTF? This contains a header file ...
73 %{_mingw32_libdir}/sigc++-2.0
74
75
76 %changelog
77 * Fri Feb  6 2009 Richard W.M. Jones <rjones@redhat.com> - 2.2.2-4
78 - Include license file.
79
80 * Fri Jan 23 2009 Richard W.M. Jones <rjones@redhat.com> - 2.2.2-3
81 - Use _smp_mflags.
82
83 * Tue Jan 13 2009 Richard W.M. Jones <rjones@redhat.com> - 2.2.2-2
84 - Requires pkgconfig.
85
86 * Fri Oct 24 2008 Richard W.M. Jones <rjones@redhat.com> - 2.2.2-1
87 - Initial RPM release.