acf9063714bc45e6f510c4a291525f9bb59a1cb5
[fedora-mingw.git] / libgsf / mingw32-libgsf.spec
1 %define __strip %{_mingw32_strip}
2 %define __objdump %{_mingw32_objdump}
3 %define _use_internal_dependency_generator 0
4 %define __find_requires %{_mingw32_findrequires}
5 %define __find_provides %{_mingw32_findprovides}
6
7 Name:           mingw32-libgsf
8 Version:        1.14.10
9 Release:        1%{?dist}
10 Summary:        MinGW Windows port of GNOME Structured File Library
11
12 License:        LGPLv2
13 Group:          Development/Libraries
14
15 URL:            http://www.gnome.org/projects/libgsf/
16 Source0:        ftp://ftp.gnome.org/pub/GNOME/sources/libgsf/1.14/libgsf-%{version}.tar.bz2
17
18 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
19 BuildArch:      noarch
20
21 BuildRequires:  mingw32-filesystem >= 35
22 BuildRequires:  mingw32-gcc
23 BuildRequires:  mingw32-binutils
24 BuildRequires:  mingw32-glib2
25 BuildRequires:  mingw32-libxml2
26 BuildRequires:  mingw32-bzip2 >= 1.0.5-4
27 BuildRequires:  mingw32-gettext
28 BuildRequires:  mingw32-iconv
29 BuildRequires:  mingw32-zlib
30 # We don't have bonobo in MinGW yet:
31 #BuildRequires:  mingw32-libbonobo
32 # We don't build Python packages yet:
33 #BuildRequires:  mingw32-pygtk2
34 # Seems like this is only needed for GNOME integration:
35 #BuildRequires:  mingw32-gnome-vfs2
36
37 BuildRequires:  autoconf, pkgconfig
38
39 Patch1000:      mingw32-libgsf-1.14.10-better-bz2-detection.patch
40 Patch1001:      mingw32-libgsf-1.14.10-glib-deprecated.patch
41
42
43 %description
44 A library for reading and writing structured files (eg MS OLE and Zip).
45
46 This is the MinGW Windows cross-compiled port of libgsf.
47
48
49 %prep
50 %setup -q -n libgsf-%{version}
51
52 %patch1000 -p1
53 %patch1001 -p1
54
55 autoconf
56
57
58 %build
59 %{_mingw32_configure} \
60   --disable-gtk-doc --disable-static \
61   --without-gnome-vfs --without-bonobo
62 make %{?_smp_mflags}
63
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67
68 export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
69 make DESTDIR=$RPM_BUILD_ROOT install
70
71 # Remove documentation which duplicates the Fedora native package.
72 rm -r $RPM_BUILD_ROOT%{_mingw32_datadir}/gtk-doc
73 rm -r $RPM_BUILD_ROOT%{_mingw32_mandir}/man1
74
75 # If native gconftool was installed then we will build the
76 # schemas.  However those are not useful under Windows because
77 # we don't have gconf itself.  Thus remove them if they were
78 # built.
79 rm -rf $RPM_BUILD_ROOT%{_mingw32_sysconfdir}/gconf
80
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85
86 %files
87 %defattr(-,root,root)
88 %{_mingw32_bindir}/gsf.exe
89 %{_mingw32_bindir}/gsf-office-thumbnailer.exe
90 %{_mingw32_bindir}/gsf-vba-dump.exe
91 %{_mingw32_bindir}/libgsf-1-114.dll
92 %{_mingw32_bindir}/libgsf-win32-1-114.dll
93 %{_mingw32_libdir}/libgsf-1.dll.a
94 %{_mingw32_libdir}/libgsf-1.la
95 %{_mingw32_libdir}/libgsf-win32-1.dll.a
96 %{_mingw32_libdir}/libgsf-win32-1.la
97 %{_mingw32_libdir}/pkgconfig/libgsf-1.pc
98 %{_mingw32_libdir}/pkgconfig/libgsf-win32-1.pc
99 %{_mingw32_includedir}/libgsf-1/
100 %{_mingw32_datadir}/locale/*/LC_MESSAGES/libgsf.mo
101
102
103 %changelog
104 * Sat Nov 22 2008 Richard W.M. Jones <rjones@redhat.com> - 1.14.10-1
105 - Initial RPM release.