Depend on mingw32-filesystem >= 41 instead of 44
[fedora-mingw.git] / libgsf / mingw32-libgsf.spec
1 %define __strip %{_mingw32_strip}
2 %define __objdump %{_mingw32_objdump}
3 %define _use_internal_dependency_generator 0
4 %define __find_requires %{_mingw32_findrequires}
5 %define __find_provides %{_mingw32_findprovides}
6
7 Name:           mingw32-libgsf
8 Version:        1.14.11
9 Release:        1%{?dist}
10 Summary:        MinGW Windows port of GNOME Structured File Library
11
12 License:        LGPLv2
13 Group:          Development/Libraries
14
15 URL:            http://www.gnome.org/projects/libgsf/
16 Source0:        ftp://ftp.gnome.org/pub/GNOME/sources/libgsf/1.14/libgsf-%{version}.tar.bz2
17
18 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
19 BuildArch:      noarch
20
21 BuildRequires:  mingw32-filesystem >= 35
22 BuildRequires:  mingw32-gcc
23 BuildRequires:  mingw32-binutils
24 BuildRequires:  mingw32-glib2
25 BuildRequires:  mingw32-libxml2
26 BuildRequires:  mingw32-bzip2 >= 1.0.5-4
27 BuildRequires:  mingw32-gettext
28 BuildRequires:  mingw32-iconv
29 BuildRequires:  mingw32-zlib
30 BuildRequires:  mingw32-dlfcn
31 # We don't have bonobo in MinGW yet:
32 #BuildRequires:  mingw32-libbonobo
33 # We don't build Python packages yet:
34 #BuildRequires:  mingw32-pygtk2
35 # Seems like this is only needed for GNOME integration:
36 #BuildRequires:  mingw32-gnome-vfs2
37
38 BuildRequires:  autoconf
39 BuildRequires:  pkgconfig
40 BuildRequires:  intltool
41
42
43 %description
44 A library for reading and writing structured files (eg MS OLE and Zip).
45
46 This is the MinGW Windows cross-compiled port of libgsf.
47
48
49 %prep
50 %setup -q -n libgsf-%{version}
51
52 autoconf
53
54
55 %build
56 %{_mingw32_configure} \
57   --disable-gtk-doc --disable-static \
58   --without-gnome-vfs --without-bonobo
59 make %{?_smp_mflags}
60
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64
65 export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
66 make DESTDIR=$RPM_BUILD_ROOT install
67
68 # Remove documentation which duplicates the Fedora native package.
69 rm -r $RPM_BUILD_ROOT%{_mingw32_datadir}/gtk-doc
70 rm -r $RPM_BUILD_ROOT%{_mingw32_mandir}/man1
71
72 # If native gconftool was installed then we will build the
73 # schemas.  However those are not useful under Windows because
74 # we don't have gconf itself.  Thus remove them if they were
75 # built.
76 rm -rf $RPM_BUILD_ROOT%{_mingw32_sysconfdir}/gconf
77 # Also gsf-office-thumbnailer only gets built if gconftool
78 # is installed.
79 rm -f $RPM_BUILD_ROOT%{_mingw32_bindir}/gsf-office-thumbnailer.exe
80
81 %find_lang libgsf
82
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87
88 %files -f libgsf.lang
89 %defattr(-,root,root)
90 %{_mingw32_bindir}/gsf.exe
91 %{_mingw32_bindir}/gsf-vba-dump.exe
92 %{_mingw32_bindir}/libgsf-1-114.dll
93 %{_mingw32_bindir}/libgsf-win32-1-114.dll
94 %{_mingw32_libdir}/libgsf-1.dll.a
95 %{_mingw32_libdir}/libgsf-1.la
96 %{_mingw32_libdir}/libgsf-win32-1.dll.a
97 %{_mingw32_libdir}/libgsf-win32-1.la
98 %{_mingw32_libdir}/pkgconfig/libgsf-1.pc
99 %{_mingw32_libdir}/pkgconfig/libgsf-win32-1.pc
100 %{_mingw32_includedir}/libgsf-1/
101
102
103 %changelog
104 * Fri Jan 23 2009 Richard W.M. Jones <rjones@redhat.com> - 1.14.11-1
105 - Rebase to native Fedora version 1.14.11.
106 - Use find_lang macro.
107 - Remove mingw32-libgsf-1.14.10-better-bz2-detection.patch, now upstream.
108 - Remove mingw32-libgsf-1.14.10-glib-deprecated.patch, now fixed upstream.
109 - +BR mingw32-dlfcn.
110
111 * Sat Nov 22 2008 Richard W.M. Jones <rjones@redhat.com> - 1.14.10-2
112 - +BR intltool.
113
114 * Sat Nov 22 2008 Richard W.M. Jones <rjones@redhat.com> - 1.14.10-1
115 - Initial RPM release.