2382bc10042387bacfcc4ef3b5665eec8d64ec16
[fedora-mingw.git] / libgsf / mingw32-libgsf.spec
1 %define __strip %{_mingw32_strip}
2 %define __objdump %{_mingw32_objdump}
3 %define _use_internal_dependency_generator 0
4 %define __find_requires %{_mingw32_findrequires}
5 %define __find_provides %{_mingw32_findprovides}
6
7 Name:           mingw32-libgsf
8 Version:        1.14.11
9 Release:        3%{?dist}
10 Summary:        MinGW Windows port of GNOME Structured File Library
11
12 License:        LGPLv2
13 Group:          Development/Libraries
14
15 URL:            http://www.gnome.org/projects/libgsf/
16 Source0:        ftp://ftp.gnome.org/pub/GNOME/sources/libgsf/1.14/libgsf-%{version}.tar.bz2
17
18 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
19 BuildArch:      noarch
20
21 BuildRequires:  mingw32-filesystem >= 35
22 BuildRequires:  mingw32-gcc
23 BuildRequires:  mingw32-binutils
24 BuildRequires:  mingw32-glib2
25 BuildRequires:  mingw32-libxml2
26 BuildRequires:  mingw32-bzip2 >= 1.0.5-4
27 BuildRequires:  mingw32-gettext
28 BuildRequires:  mingw32-iconv
29 BuildRequires:  mingw32-zlib
30 BuildRequires:  mingw32-dlfcn
31 # We don't have bonobo in MinGW yet:
32 #BuildRequires:  mingw32-libbonobo
33 # We don't build Python packages yet:
34 #BuildRequires:  mingw32-pygtk2
35 # Seems like this is only needed for GNOME integration:
36 #BuildRequires:  mingw32-gnome-vfs2
37
38 BuildRequires:  autoconf
39 BuildRequires:  pkgconfig
40 BuildRequires:  intltool
41
42 Requires:       pkgconfig
43
44
45 %description
46 A library for reading and writing structured files (eg MS OLE and Zip).
47
48 This is the MinGW Windows cross-compiled port of libgsf.
49
50
51 %prep
52 %setup -q -n libgsf-%{version}
53
54 autoconf
55
56
57 %build
58 %{_mingw32_configure} \
59   --disable-gtk-doc --disable-static \
60   --without-gnome-vfs --without-bonobo
61 make %{?_smp_mflags}
62
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66
67 export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
68 make DESTDIR=$RPM_BUILD_ROOT install
69
70 # Remove documentation which duplicates the Fedora native package.
71 rm -r $RPM_BUILD_ROOT%{_mingw32_datadir}/gtk-doc
72 rm -r $RPM_BUILD_ROOT%{_mingw32_mandir}/man1
73
74 # If native gconftool was installed then we will build the
75 # schemas.  However those are not useful under Windows because
76 # we don't have gconf itself.  Thus remove them if they were
77 # built.
78 rm -rf $RPM_BUILD_ROOT%{_mingw32_sysconfdir}/gconf
79 # Also gsf-office-thumbnailer only gets built if gconftool
80 # is installed.
81 rm -f $RPM_BUILD_ROOT%{_mingw32_bindir}/gsf-office-thumbnailer.exe
82
83 %find_lang libgsf
84
85
86 %clean
87 rm -rf $RPM_BUILD_ROOT
88
89
90 %files -f libgsf.lang
91 %defattr(-,root,root)
92 %doc COPYING COPYING.LIB
93 %{_mingw32_bindir}/gsf.exe
94 %{_mingw32_bindir}/gsf-vba-dump.exe
95 %{_mingw32_bindir}/libgsf-1-114.dll
96 %{_mingw32_bindir}/libgsf-win32-1-114.dll
97 %{_mingw32_libdir}/libgsf-1.dll.a
98 %{_mingw32_libdir}/libgsf-1.la
99 %{_mingw32_libdir}/libgsf-win32-1.dll.a
100 %{_mingw32_libdir}/libgsf-win32-1.la
101 %{_mingw32_libdir}/pkgconfig/libgsf-1.pc
102 %{_mingw32_libdir}/pkgconfig/libgsf-win32-1.pc
103 %{_mingw32_includedir}/libgsf-1/
104
105
106 %changelog
107 * Fri Feb  6 2009 Richard W.M. Jones <rjones@redhat.com> - 1.14.11-3
108 - Include license files.
109
110 * Fri Jan 30 2009 Richard W.M. Jones <rjones@redhat.com> - 1.14.11-2
111 - Requires pkgconfig.
112
113 * Fri Jan 23 2009 Richard W.M. Jones <rjones@redhat.com> - 1.14.11-1
114 - Rebase to native Fedora version 1.14.11.
115 - Use find_lang macro.
116 - Remove mingw32-libgsf-1.14.10-better-bz2-detection.patch, now upstream.
117 - Remove mingw32-libgsf-1.14.10-glib-deprecated.patch, now fixed upstream.
118 - +BR mingw32-dlfcn.
119
120 * Sat Nov 22 2008 Richard W.M. Jones <rjones@redhat.com> - 1.14.10-2
121 - +BR intltool.
122
123 * Sat Nov 22 2008 Richard W.M. Jones <rjones@redhat.com> - 1.14.10-1
124 - Initial RPM release.