smock: use $basearch in smock.mock.extra
[fedora-mingw.git] / inkscape / mingw32-inkscape.spec
1 # NB: Not for a Fedora package, just an example to show how
2 # to build Inkscape using the cross-compiler.
3
4 %define __strip %{_mingw32_strip}
5 %define __objdump %{_mingw32_objdump}
6 %define _use_internal_dependency_generator 0
7 %define __find_requires %{_mingw32_findrequires}
8 %define __find_provides %{_mingw32_findprovides}
9
10 %define svnrev 20568
11
12 Name:           mingw32-inkscape
13 Version:        0.47
14 Release:        0.2.svn%{svnrev}%{?dist}
15 Summary:        MinGW Windows port of Inkscape vector graphics editor
16
17 License:        LGPLv2+
18 Group:          Development/Libraries
19 URL:            http://www.inkscape.org/
20
21 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
22
23 Source0:        http://inkscape.modevia.com/svn-snap/inkscape-%{svnrev}.tar.bz2
24
25 # Rolled-up source patch, submitted upstream on 2008-10-27.
26 #Patch0:         mingw32-inkscape-20081027.patch
27
28 # Fix the paths.
29 Patch1:         mingw32-inkscape-20081027-paths.patch
30
31 # This patch is only needed to run under Wine, which doesn't
32 # supported getting the outline of unhinted fonts.
33 Patch2:         mingw32-inkscape-20081027-unhinted-fonts-for-wine.patch
34
35 # Fixes for gcc 4.4
36 Patch3:         mingw32-inkscape-20568-gcc44.patch
37
38 BuildArch:      noarch
39
40 BuildRequires:  mingw32-filesystem >= 40
41 BuildRequires:  mingw32-gcc
42 BuildRequires:  mingw32-gcc-c++
43 BuildRequires:  mingw32-binutils
44 BuildRequires:  mingw32-fontconfig
45 BuildRequires:  mingw32-freetype
46 BuildRequires:  mingw32-glibmm24
47 BuildRequires:  mingw32-cairomm
48 BuildRequires:  mingw32-pangomm
49 BuildRequires:  mingw32-gtkmm24
50 BuildRequires:  mingw32-popt
51 BuildRequires:  mingw32-libxml2
52 BuildRequires:  mingw32-libxslt
53 BuildRequires:  mingw32-gc
54 BuildRequires:  mingw32-gsl
55 BuildRequires:  mingw32-boost
56 BuildRequires:  mingw32-libsigc++20
57
58 BuildRequires:  autoconf, automake, libtool, intltool
59
60 # For /usr/bin/glib-gettextize
61 BuildRequires:  glib2-devel
62
63
64 %description
65 An Open Source vector graphics editor, with capabilities similar to
66 Illustrator, CorelDraw, or Xara X, using the W3C standard Scalable
67 Vector Graphics (SVG) file format.
68
69 Inkscape supports many advanced SVG features (markers, clones, alpha
70 blending, etc.) and great care is taken in designing a streamlined
71 interface. It is very easy to edit nodes, perform complex path
72 operations, trace bitmaps and much more. We also aim to maintain a
73 thriving user and developer community by using open,
74 community-oriented development.
75
76
77 %prep
78 %setup -q -n inkscape-%{svnrev}
79 #%patch0 -p0
80 %patch1 -p0
81 %patch2 -p0
82 %patch3 -p1
83
84 ./autogen.sh
85
86
87 %build
88 PATH=%{_mingw32_bindir}:$PATH \
89 %{_mingw32_configure} \
90   --enable-lcms=no \
91   --without-gnome-vfs
92 make %{?_smp_mflags}
93
94
95 %install
96 rm -rf $RPM_BUILD_ROOT
97 make DESTDIR=$RPM_BUILD_ROOT install
98
99
100 %clean
101 rm -rf $RPM_BUILD_ROOT
102
103
104 %files
105 %defattr(-,root,root)
106 %{_mingw32_bindir}/inkscape.exe
107 %{_mingw32_bindir}/inkview.exe
108 %{_mingw32_datadir}/applications/inkscape.desktop
109 %{_mingw32_datadir}/inkscape/
110 %{_mingw32_datadir}/locale/*/LC_MESSAGES/inkscape.mo
111 %{_mingw32_datadir}/pixmaps/inkscape.png
112 %{_mingw32_mandir}/*/man1/*.1
113 %{_mingw32_mandir}/man1/*.1
114
115
116 %changelog
117 * Fri Feb 20 2009 Richard W.M. Jones <rjones@redhat.com> - 0.47-0.2.svn20568
118 - Rebuild for mingw32-gcc 4.4
119
120 * Sun Jan 25 2009 Richard W.M. Jones <rjones@redhat.com> - 0.47-0.1.svn20568
121 - Initial RPM release.