These can build with mingw32-filesystem in F-10, provided that the
[fedora-mingw.git] / inkscape / mingw32-inkscape.spec
1 # NB: Not for a Fedora package, just an example to show how
2 # to build Inkscape using the cross-compiler.
3
4 %define __strip %{_mingw32_strip}
5 %define __objdump %{_mingw32_objdump}
6 %define _use_internal_dependency_generator 0
7 %define __find_requires %{_mingw32_findrequires}
8 %define __find_provides %{_mingw32_findprovides}
9
10 %define svnrev 20568
11
12 Name:           mingw32-inkscape
13 Version:        0.47
14 Release:        0.1.svn%{svnrev}%{?dist}
15 Summary:        MinGW Windows port of Inkscape vector graphics editor
16
17 License:        LGPLv2+
18 Group:          Development/Libraries
19 URL:            http://www.inkscape.org/
20
21 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
22
23 Source0:        http://inkscape.modevia.com/svn-snap/inkscape-%{svnrev}.tar.bz2
24
25 # Rolled-up source patch, submitted upstream on 2008-10-27.
26 #Patch0:         mingw32-inkscape-20081027.patch
27
28 # Fix the paths.
29 Patch1:         mingw32-inkscape-20081027-paths.patch
30
31 # This patch is only needed to run under Wine, which doesn't
32 # supported getting the outline of unhinted fonts.
33 Patch2:         mingw32-inkscape-20081027-unhinted-fonts-for-wine.patch
34
35 BuildArch:      noarch
36
37 BuildRequires:  mingw32-filesystem >= 40
38 BuildRequires:  mingw32-gcc
39 BuildRequires:  mingw32-gcc-c++
40 BuildRequires:  mingw32-binutils
41 BuildRequires:  mingw32-fontconfig
42 BuildRequires:  mingw32-freetype
43 BuildRequires:  mingw32-glibmm24
44 BuildRequires:  mingw32-cairomm
45 BuildRequires:  mingw32-pangomm
46 BuildRequires:  mingw32-gtkmm24
47 BuildRequires:  mingw32-popt
48 BuildRequires:  mingw32-libxml2
49 BuildRequires:  mingw32-libxslt
50 BuildRequires:  mingw32-gc
51 BuildRequires:  mingw32-gsl
52 BuildRequires:  mingw32-boost
53 BuildRequires:  mingw32-libsigc++20
54
55 BuildRequires:  autoconf, automake, libtool, intltool
56
57 # For /usr/bin/glib-gettextize
58 BuildRequires:  glib2-devel
59
60
61 %description
62 An Open Source vector graphics editor, with capabilities similar to
63 Illustrator, CorelDraw, or Xara X, using the W3C standard Scalable
64 Vector Graphics (SVG) file format.
65
66 Inkscape supports many advanced SVG features (markers, clones, alpha
67 blending, etc.) and great care is taken in designing a streamlined
68 interface. It is very easy to edit nodes, perform complex path
69 operations, trace bitmaps and much more. We also aim to maintain a
70 thriving user and developer community by using open,
71 community-oriented development.
72
73
74 %prep
75 %setup -q -n inkscape-%{svnrev}
76 #%patch0 -p0
77 %patch1 -p0
78 %patch2 -p0
79
80 ./autogen.sh
81
82
83 %build
84 PATH=%{_mingw32_bindir}:$PATH \
85 %{_mingw32_configure} \
86   --enable-lcms=no \
87   --without-gnome-vfs
88 make %{?_smp_mflags}
89
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93 make DESTDIR=$RPM_BUILD_ROOT install
94
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99
100 %files
101 %defattr(-,root,root)
102 %{_mingw32_bindir}/inkscape.exe
103 %{_mingw32_bindir}/inkview.exe
104 %{_mingw32_datadir}/applications/inkscape.desktop
105 %{_mingw32_datadir}/inkscape/
106 %{_mingw32_datadir}/locale/*/LC_MESSAGES/inkscape.mo
107 %{_mingw32_datadir}/pixmaps/inkscape.png
108 %{_mingw32_mandir}/*/man1/*.1
109 %{_mingw32_mandir}/man1/*.1
110
111
112 %changelog
113 * Sun Jan 25 2009 Richard W.M. Jones <rjones@redhat.com> - 0.47-0.1.svn20568
114 - Initial RPM release.