9f88dd5c64f946518ea8721a7d1728578242608f
[fedora-mingw.git] / iconv / mingw32-iconv.spec
1 %define __strip %{_mingw32_strip}
2 %define __objdump %{_mingw32_objdump}
3 %define _use_internal_dependency_generator 0
4 %define __find_requires %{_mingw32_findrequires}
5 %define __find_provides %{_mingw32_findprovides}
6
7 Name:      mingw32-iconv
8 Version:   1.12
9 Release:   6%{?dist}
10 Summary:   GNU libraries and utilities for character set conversion
11
12 License:   GPLv2+ and LGPLv2+
13 Group:     Development/Libraries
14 URL:       http://www.gnu.org/software/libiconv/
15 Source0:   http://ftp.gnu.org/pub/gnu/libiconv/libiconv-%{version}.tar.gz
16 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17 BuildArch: noarch
18
19 BuildRequires: mingw32-filesystem >= 23
20 BuildRequires: mingw32-gcc
21 BuildRequires: mingw32-binutils
22
23 # There's a quasi-circular dependency between mingw32-iconv and
24 # mingw32-gettext.  If gettext is installed when you build this then
25 # iconv will create *.mo files.  When this package is added to Fedora
26 # we can consider adding this circular dep:
27 #BuildRequires: mingw32-gettext
28
29
30 %description
31 MinGW Windows Iconv library
32
33
34 %prep
35 %setup -q -n libiconv-%{version}
36
37
38 %build
39 %{_mingw32_configure}
40 make
41
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45
46 make DESTDIR=$RPM_BUILD_ROOT install
47
48 # Remove documentation which duplicates what is already in
49 # Fedora native packages.
50 rm -rf $RPM_BUILD_ROOT%{_mingw32_docdir}/libiconv/
51 rm -rf $RPM_BUILD_ROOT%{_mingw32_mandir}
52
53 # If mingw32-gettext was installed during the build, remove the *.mo
54 # files.  If mingw32-gettext wasn't installed then there won't be any.
55 rm -rf $RPM_BUILD_ROOT%{_mingw32_datadir}/locale
56
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61
62 %files
63 %defattr(-,root,root)
64 %doc COPYING COPYING.LIB
65 %{_mingw32_bindir}/iconv
66 %{_mingw32_bindir}/libcharset-1.dll
67 %{_mingw32_bindir}/libiconv-2.dll
68 %{_mingw32_includedir}/iconv.h
69 %{_mingw32_includedir}/libcharset.h
70 %{_mingw32_includedir}/localcharset.h
71 %{_mingw32_libdir}/charset.alias
72 %{_mingw32_libdir}/libcharset.a
73 %{_mingw32_libdir}/libcharset.dll.a
74 %{_mingw32_libdir}/libcharset.la
75 %{_mingw32_libdir}/libiconv.dll.a
76 %{_mingw32_libdir}/libiconv.la
77
78
79 %changelog
80 * Fri Dec 19 2008 Richard W.M. Jones <rjones@redhat.com> - 0.17-6
81 - Include the license files in doc section.
82
83 * Mon Nov  3 2008 Richard W.M. Jones <rjones@redhat.com> - 0.17-5
84 - Changed the summary (Bruno Haible).
85 - Note about mingw32-gettext / Remove *.mo files.
86
87 * Wed Sep 24 2008 Richard W.M. Jones <rjones@redhat.com> - 0.17-4
88 - Rename mingw -> mingw32.
89
90 * Thu Sep  4 2008 Richard W.M. Jones <rjones@redhat.com> - 0.17-3
91 - Remove documentation which duplicates what is in Fedora native packages.
92
93 * Thu Sep  4 2008 Richard W.M. Jones <rjones@redhat.com> - 0.17-2
94 - Use RPM macros from mingw-filesystem.
95
96 * Tue Sep  2 2008 Daniel P. Berrange <berrange@redhat.com> - 0.17-1
97 - Initial RPM release, largely based on earlier work from several sources.