- Remove documentation.
[fedora-mingw.git] / gtk2 / mingw32-gtk2.spec
1 %define __strip %{_mingw32_strip}
2 %define __objdump %{_mingw32_objdump}
3 %define _use_internal_dependency_generator 0
4 %define __find_requires %{_mingw32_findrequires}
5 %define __find_provides %{_mingw32_findprovides}
6
7 Name:           mingw32-gtk2
8 Version:        2.15.0
9 Release:        3%{?dist}
10 Summary:        MinGW Windows Gtk2 library
11
12 License:        LGPLv2+
13 Group:          Development/Libraries
14 URL:            http://www.gtk.org
15 Source0:        http://download.gnome.org/sources/gtk+/2.15/gtk+-%{version}.tar.bz2
16
17 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
18
19 # If you want to rebuild this, do:
20 # wine %{_mingw32_bindir}/gdk-pixbuf-query-loaders.exe > gdk-pixbuf.loaders
21 Source1:        gdk-pixbuf.loaders
22
23 # Fix use of extended buttons in gtkstatusicon.
24 Patch1000:      mingw32-gtk2-2.15.0-xbuttons.patch
25
26 BuildArch:      noarch
27
28 BuildRequires:  mingw32-filesystem >= 40
29 BuildRequires:  mingw32-gcc
30 BuildRequires:  mingw32-binutils
31
32 BuildRequires:  mingw32-atk >= 1.13.0
33 BuildRequires:  mingw32-cairo >= 1.8.0
34 BuildRequires:  mingw32-dlfcn
35 BuildRequires:  mingw32-gettext
36 BuildRequires:  mingw32-glib2 >= 2.17.7
37 BuildRequires:  mingw32-iconv
38 BuildRequires:  mingw32-jasper
39 BuildRequires:  mingw32-libjpeg
40 BuildRequires:  mingw32-libpng >= 1.2.2
41 BuildRequires:  mingw32-pango >= 1.20.0
42 BuildRequires:  mingw32-pixman
43 BuildRequires:  mingw32-zlib
44
45 BuildRequires:  pkgconfig
46
47 # Native one for msgfmt
48 BuildRequires:  gettext
49 # Native one for glib-genmarsjal
50 BuildRequires:  glib2-devel
51 # Native one for gtk-update-icon-cache
52 BuildRequires:  gtk2
53 # Native one for gdk-pixbuf-csource
54 BuildRequires:  gtk2-devel
55
56 Requires:       pkgconfig
57
58
59 %description
60 MinGW Windows Gtk2 library.
61
62
63 %prep
64 %setup -q -n gtk+-%{version}
65
66 %patch1000 -p1
67
68
69 %build
70 # Need to run the correct version of glib-mkenums.
71 PATH=%{_mingw32_bindir}:$PATH
72
73 %{_mingw32_configure} --disable-cups --disable-static
74 make %{?_smp_mflags}
75
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79
80 make DESTDIR=$RPM_BUILD_ROOT install
81
82 rm -f $RPM_BUILD_ROOT/%{_mingw32_libdir}/charset.alias
83
84 # Remove manpages which duplicate those in Fedora native.
85 rm -rf $RPM_BUILD_ROOT%{_mingw32_mandir}
86
87 # Remove documentation too.
88 rm -rf $RPM_BUILD_ROOT%{_mingw32_datadir}/gtk-doc
89
90 # Install gdk-pixbuf.loaders.
91 mkdir -p $RPM_BUILD_ROOT%{_mingw32_sysconfdir}/gtk-2.0/
92 install -m 0644 %{SOURCE1} $RPM_BUILD_ROOT%{_mingw32_sysconfdir}/gtk-2.0/
93
94 %find_lang %{name} --all-name
95
96
97 %clean
98 rm -rf $RPM_BUILD_ROOT
99
100
101 %files -f %{name}.lang
102 %defattr(-,root,root)
103 %doc COPYING
104 %{_mingw32_datadir}/themes/*
105 %{_mingw32_bindir}/gdk-pixbuf-csource.exe
106 %{_mingw32_bindir}/gdk-pixbuf-query-loaders.exe
107 %{_mingw32_bindir}/gtk-builder-convert
108 %{_mingw32_bindir}/gtk-demo.exe
109 %{_mingw32_bindir}/gtk-query-immodules-2.0.exe
110 %{_mingw32_bindir}/gtk-update-icon-cache.exe
111 %{_mingw32_bindir}/libgailutil-18.dll
112 %{_mingw32_bindir}/libgdk-win32-2.0-0.dll
113 %{_mingw32_bindir}/libgdk_pixbuf-2.0-0.dll
114 %{_mingw32_bindir}/libgtk-win32-2.0-0.dll
115 %{_mingw32_libdir}/gtk-2.0/
116 %{_mingw32_libdir}/libgailutil.dll.a
117 %{_mingw32_libdir}/libgailutil.la
118 %{_mingw32_libdir}/libgdk-win32-2.0.dll.a
119 %{_mingw32_libdir}/libgdk-win32-2.0.la
120 %{_mingw32_libdir}/libgdk_pixbuf-2.0.dll.a
121 %{_mingw32_libdir}/libgdk_pixbuf-2.0.la
122 %{_mingw32_libdir}/libgtk-win32-2.0.dll.a
123 %{_mingw32_libdir}/libgtk-win32-2.0.la
124 %{_mingw32_libdir}/gdk_pixbuf-2.0.def
125 %{_mingw32_libdir}/gdk-win32-2.0.def
126 %{_mingw32_libdir}/gtk-win32-2.0.def
127 %{_mingw32_libdir}/pkgconfig/gail.pc
128 %{_mingw32_libdir}/pkgconfig/gdk-2.0.pc
129 %{_mingw32_libdir}/pkgconfig/gdk-win32-2.0.pc
130 %{_mingw32_libdir}/pkgconfig/gdk-pixbuf-2.0.pc
131 %{_mingw32_libdir}/pkgconfig/gtk+-2.0.pc
132 %{_mingw32_libdir}/pkgconfig/gtk+-win32-2.0.pc
133 %{_mingw32_includedir}/gtk-2.0/
134 %{_mingw32_includedir}/gail-1.0/
135 %{_mingw32_sysconfdir}/gtk-2.0/
136 %{_mingw32_datadir}/aclocal/gtk-2.0.m4
137 %{_mingw32_datadir}/gtk-2.0/
138
139
140 %changelog
141 * Fri Feb  6 2009 Richard W.M. Jones <rjones@redhat.com> - 2.15.0-3
142 - Remove documentation.
143 - Add license file.
144 - Added extra BRs suggested by auto-buildrequires.
145
146 * Fri Jan 30 2009 Richard W.M. Jones <rjones@redhat.com> - 2.15.0-2
147 - Requires pkgconfig.
148
149 * Fri Jan 23 2009 Richard W.M. Jones <rjones@redhat.com> - 2.15.0-1
150 - Rebase to Fedora native version 2.15.0.
151 - Disable static libraries.
152 - Use _smp_mflags.
153 - Use find_lang macro.
154
155 * Mon Oct 27 2008 Richard W.M. Jones <rjones@redhat.com> - 2.14.4-3
156 - Remove preun script, no longer used.
157
158 * Fri Oct 24 2008 Richard W.M. Jones <rjones@redhat.com> - 2.14.4-1
159 - New upstream version 2.14.4.
160 - Require cairo >= 1.8.0 because of important fixes.
161 - Remove a couple of patches which are now upstream.
162
163 * Fri Oct 10 2008 Richard W.M. Jones <rjones@redhat.com> - 2.14.2-3
164 - Remove the requirement for Wine at build or install time.
165 - Conflicts with (native) cups-devel.
166
167 * Wed Sep 24 2008 Richard W.M. Jones <rjones@redhat.com> - 2.14.2-2
168 - Rename mingw -> mingw32.
169
170 * Mon Sep 22 2008 Daniel P. Berrange <berrange@redhat.com> - 2.14.2-1
171 - Update to 2.14.2 release
172
173 * Sun Sep 21 2008 Richard W.M. Jones <rjones@redhat.com> - 2.14.0-5
174 - Remove manpages duplicating those in Fedora native packages.
175
176 * Thu Sep 11 2008 Daniel P. Berrange <berrange@redhat.com> - 2.14.0-4
177 - Added dep on pkgconfig, gettext and glib2 (native)
178
179 * Thu Sep 11 2008 Richard W.M. Jones <rjones@redhat.com> - 2.14.0-3
180 - post/preun scripts to update the gdk-pixbuf.loaders list.
181
182 * Wed Sep 10 2008 Richard W.M. Jones <rjones@redhat.com> - 2.14.0-2
183 - Jasper DLLs now fixed.
184 - Fix source URL.
185 - Run the correct glib-mkenums.
186
187 * Tue Sep  9 2008 Daniel P. Berrange <berrange@redhat.com> - 2.14.0-1
188 - Initial RPM release