- Remove gtk-doc.
[fedora-mingw.git] / gtk-vnc / mingw32-gtk-vnc.spec
1 %define __strip %{_mingw32_strip}
2 %define __objdump %{_mingw32_objdump}
3 %define _use_internal_dependency_generator 0
4 %define __find_requires %{_mingw32_findrequires}
5 %define __find_provides %{_mingw32_findprovides}
6
7 %define _default_patch_fuzz 2
8
9 Name:           mingw32-gtk-vnc
10 Version:        0.3.8
11 Release:        0.3.20081030hg%{?dist}
12 Summary:        MinGW Windows port of VNC client GTK widget
13
14 License:        LGPLv2+
15 Group:          Development/Libraries
16 URL:            http://gtk-vnc.sf.net/
17 Source0:        gtk-vnc-0.3.8-20081030.tar.gz
18 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
19
20 # Patches submitted upstream 2008-10-28/29/30:
21 Patch100:       gtk-vnc-00-win32.patch
22 Patch101:       gtk-vnc-01-recv.patch
23 Patch102:       gtk-vnc-02-ioctl.patch
24 Patch103:       gtk-vnc-03-wsastartup.patch
25 #Patch104:       gtk-vnc-hgignore.patch
26 Patch105:       gtk-vnc-ldflags-confusion.patch
27 Patch106:       gtk-vnc-dan-fd-fix.patch
28
29 BuildArch:      noarch
30
31 BuildRequires:  mingw32-filesystem >= 30
32 BuildRequires:  mingw32-gcc
33 BuildRequires:  mingw32-binutils
34 BuildRequires:  mingw32-gtk2
35 BuildRequires:  mingw32-gnutls
36 BuildRequires:  autoconf
37 BuildRequires:  automake
38 BuildRequires:  libtool
39 BuildRequires:  pkgconfig
40
41
42 %description
43 gtk-vnc is a VNC viewer widget for GTK. It is built using coroutines
44 allowing it to be completely asynchronous while remaining single threaded.
45
46
47 %prep
48 %setup -q -n gtk-vnc-0.3.7
49
50 %patch100 -p1
51 %patch101 -p1
52 %patch102 -p1
53 %patch103 -p1
54 #%patch104 -p1
55 %patch105 -p1
56 %patch106 -p1
57
58 libtoolize --force --copy
59 autoreconf
60
61
62 %build
63 %{_mingw32_configure} --without-python --with-examples --disable-static
64 make %{?_smp_mflags}
65
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69 make DESTDIR=$RPM_BUILD_ROOT install
70
71 # automake gives gvncviewer a strange name ...
72 mv $RPM_BUILD_ROOT%{_mingw32_bindir}/i686-pc-mingw32-gvncviewer.exe \
73    $RPM_BUILD_ROOT%{_mingw32_bindir}/gvncviewer.exe \
74
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79
80 %files
81 %defattr(-,root,root)
82 %{_mingw32_bindir}/gvncviewer.exe
83 %{_mingw32_bindir}/libgtk-vnc-1.0-0.dll
84 %{_mingw32_libdir}/libgtk-vnc-1.0.dll.a
85 %{_mingw32_libdir}/libgtk-vnc-1.0.la
86 %{_mingw32_libdir}/pkgconfig/gtk-vnc-1.0.pc
87 %{_mingw32_includedir}/gtk-vnc-1.0
88
89
90 %changelog
91 * Fri Jan 23 2009 Richard W.M. Jones <rjones@redhat.com> - 0.3.8-0.3.20081030hg
92 - Use _smp_mflags.
93 - Disable static library.
94 - Rebuild libtool.
95
96 * Thu Oct 30 2008 Richard W.M. Jones <rjones@redhat.com> - 0.3.8-0.2.20081030hg
97 - Add Dan's fd/socket fix for Windows.
98
99 * Thu Oct 30 2008 Richard W.M. Jones <rjones@redhat.com> - 0.3.8-0.1.20081030hg
100 - Upgrade to current version in Mercurial (pre-release of 0.3.8).
101 - More MinGW patches.
102
103 * Fri Oct 10 2008 Richard W.M. Jones <rjones@redhat.com> - 0.3.7-3
104 - Missing BRs discovered by mock.
105 - Added description section.
106
107 * Thu Oct  9 2008 Richard W.M. Jones <rjones@redhat.com> - 0.3.7-2
108 - Initial RPM release.