Updated .hgignore file.
[fedora-mingw.git] / gtk-vnc / mingw32-gtk-vnc.spec
1 %define __strip %{_mingw32_strip}
2 %define __objdump %{_mingw32_objdump}
3 %define _use_internal_dependency_generator 0
4 %define __find_requires %{_mingw32_findrequires}
5 %define __find_provides %{_mingw32_findprovides}
6
7 %define _default_patch_fuzz 2
8
9 Name:           mingw32-gtk-vnc
10 Version:        0.3.8
11 Release:        3%{?dist}
12 Summary:        MinGW Windows port of VNC client GTK widget
13
14 License:        LGPLv2+
15 Group:          Development/Libraries
16 URL:            http://sourceforge.net/projects/gtk-vnc
17 Source0:        http://downloads.sourceforge.net/gtk-vnc/gtk-vnc-%{version}.tar.gz
18 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
19
20 BuildArch:      noarch
21
22 BuildRequires:  mingw32-filesystem >= 40
23 BuildRequires:  mingw32-gcc
24 BuildRequires:  mingw32-binutils
25
26 BuildRequires:  mingw32-cairo
27 BuildRequires:  mingw32-dlfcn
28 BuildRequires:  mingw32-gettext
29 BuildRequires:  mingw32-iconv
30 BuildRequires:  mingw32-gnutls
31 BuildRequires:  mingw32-gtk2
32 BuildRequires:  pkgconfig
33
34 Requires:       pkgconfig
35
36
37 %description
38 gtk-vnc is a VNC viewer widget for GTK. It is built using coroutines
39 allowing it to be completely asynchronous while remaining single threaded.
40
41
42 %prep
43 %setup -q -n gtk-vnc-%{version}
44
45
46 %build
47 %{_mingw32_configure} --without-python --with-examples --disable-static
48 make %{?_smp_mflags}
49
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 make DESTDIR=$RPM_BUILD_ROOT install
54
55 # automake gives gvncviewer a strange name ...
56 mv $RPM_BUILD_ROOT%{_mingw32_bindir}/i686-pc-mingw32-gvncviewer.exe \
57    $RPM_BUILD_ROOT%{_mingw32_bindir}/gvncviewer.exe \
58
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63
64 %files
65 %defattr(-,root,root)
66 %doc COPYING.LIB
67 %{_mingw32_bindir}/gvncviewer.exe
68 %{_mingw32_bindir}/libgtk-vnc-1.0-0.dll
69 %{_mingw32_libdir}/libgtk-vnc-1.0.dll.a
70 %{_mingw32_libdir}/libgtk-vnc-1.0.la
71 %{_mingw32_libdir}/pkgconfig/gtk-vnc-1.0.pc
72 %{_mingw32_includedir}/gtk-vnc-1.0
73
74
75 %changelog
76 * Fri Feb  6 2009 Richard W.M. Jones <rjones@redhat.com> - 0.3.8-3
77 - Downgrade mingw32-filesystem version so it can still build on F-10.
78
79 * Fri Feb  6 2009 Richard W.M. Jones <rjones@redhat.com> - 0.3.8-2
80 - Needs mingw32-filesystem with the pkg-config library path fix.
81 - Added optional BRs suggested by auto-buildrequires.
82 - Include the license file.
83
84 * Tue Feb  3 2009 Michel Salim <salimma@fedoraproject.org> - 0.3.8-1
85 - Update to 0.3.8
86
87 * Fri Jan 30 2009 Richard W.M. Jones <rjones@redhat.com> - 0.3.8-0.4.20081030hg
88 - Requires pkgconfig.
89
90 * Fri Jan 23 2009 Richard W.M. Jones <rjones@redhat.com> - 0.3.8-0.3.20081030hg
91 - Use _smp_mflags.
92 - Disable static library.
93 - Rebuild libtool.
94
95 * Thu Oct 30 2008 Richard W.M. Jones <rjones@redhat.com> - 0.3.8-0.2.20081030hg
96 - Add Dan's fd/socket fix for Windows.
97
98 * Thu Oct 30 2008 Richard W.M. Jones <rjones@redhat.com> - 0.3.8-0.1.20081030hg
99 - Upgrade to current version in Mercurial (pre-release of 0.3.8).
100 - More MinGW patches.
101
102 * Fri Oct 10 2008 Richard W.M. Jones <rjones@redhat.com> - 0.3.7-3
103 - Missing BRs discovered by mock.
104 - Added description section.
105
106 * Thu Oct  9 2008 Richard W.M. Jones <rjones@redhat.com> - 0.3.7-2
107 - Initial RPM release.