Rename base packages mingw -> mingw32.
[fedora-mingw.git] / filesystem / mingw32-filesystem.spec
1 %define debug_package %{nil}
2
3 Name:           mingw32-filesystem
4 Version:        26
5 Release:        1%{?dist}
6 Summary:        MinGW base filesystem and environment
7
8 Group:          Development/Libraries
9 License:        GPLv2+
10 URL:            http://hg.et.redhat.com/misc/fedora-mingw--devel/
11 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
12 BuildArch:      noarch
13
14 Source0:        mingw32-COPYING
15 Source1:        mingw32-macros.mingw32
16 Source2:        mingw32.sh
17 Source3:        mingw32.csh
18 Source4:        mingw32-find-requires.sh
19 Source5:        mingw32-find-provides.sh
20
21 Requires:       setup
22 Requires:       rpm
23
24 # These are actually provided by Windows itself, or Wine.
25 Provides:       mingw32(msvcrt.dll)
26 Provides:       mingw32(kernel32.dll)
27 Provides:       mingw32(user32.dll)
28 Provides:       mingw32(gdi32.dll)
29 Provides:       mingw32(ole32.dll)
30
31 Obsoletes:      mingw-filesystem = %{version}-%{release}
32 Provides:       mingw-filesystem < 26
33
34
35 %description
36 This package contains the base filesystem layout, RPM macros and
37 environment for all Fedora MinGW packages.
38
39 This environment is maintained by the Fedora MinGW SIG at:
40
41   http://fedoraproject.org/wiki/SIGs/MinGW
42
43
44 %prep
45 %setup -q -c -T
46 cp %{SOURCE0} COPYING
47 sed 's/@VERSION@/%{version}/' < %{SOURCE4} > mingw32-find-requires.sh
48
49
50 %build
51 # nothing
52
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56
57 mkdir -p $RPM_BUILD_ROOT
58
59 mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
60 install -m 644 %{SOURCE2} %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
61
62 mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/rpm
63 install -m 644 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.mingw32
64
65 mkdir -p $RPM_BUILD_ROOT%{_prefix}/i686-pc-mingw32
66
67 # GCC requires these directories, even though they contain links
68 # to binaries which are also installed in /usr/bin etc.  These
69 # contain Fedora native binaries.
70 mkdir -p $RPM_BUILD_ROOT%{_prefix}/i686-pc-mingw32/bin
71 mkdir -p $RPM_BUILD_ROOT%{_prefix}/i686-pc-mingw32/lib
72
73 # The MinGW system root which will contain Windows native binaries
74 # and Windows-specific header files, pkgconfig, etc.
75 mkdir -p $RPM_BUILD_ROOT%{_prefix}/i686-pc-mingw32/sys-root/mingw
76 mkdir -p $RPM_BUILD_ROOT%{_prefix}/i686-pc-mingw32/sys-root/mingw/bin
77 mkdir -p $RPM_BUILD_ROOT%{_prefix}/i686-pc-mingw32/sys-root/mingw/include
78 mkdir -p $RPM_BUILD_ROOT%{_prefix}/i686-pc-mingw32/sys-root/mingw/include/sys
79 mkdir -p $RPM_BUILD_ROOT%{_prefix}/i686-pc-mingw32/sys-root/mingw/lib
80 mkdir -p $RPM_BUILD_ROOT%{_prefix}/i686-pc-mingw32/sys-root/mingw/lib/pkgconfig
81
82 mkdir -p $RPM_BUILD_ROOT%{_prefix}/i686-pc-mingw32/sys-root/mingw/share/aclocal
83
84 # We don't normally package manual pages and info files, except
85 # where those are not supplied by a Fedora native package.  So we
86 # need to create the directories.
87 #
88 # Note that some packages try to install stuff in
89 #   /usr/i686-pc-mingw32/sys-root/mingw/man and
90 #   /usr/i686-pc-mingw32/sys-root/mingw/doc
91 # but those are both packaging bugs.
92 mkdir -p $RPM_BUILD_ROOT%{_prefix}/i686-pc-mingw32/sys-root/mingw/share
93 mkdir -p $RPM_BUILD_ROOT%{_prefix}/i686-pc-mingw32/sys-root/mingw/share/doc
94 mkdir -p $RPM_BUILD_ROOT%{_prefix}/i686-pc-mingw32/sys-root/mingw/share/info
95 mkdir -p $RPM_BUILD_ROOT%{_prefix}/i686-pc-mingw32/sys-root/mingw/share/man
96 mkdir -p $RPM_BUILD_ROOT%{_prefix}/i686-pc-mingw32/sys-root/mingw/share/man/man{1,2,3,4,5,6,7,8,l,n}
97
98 # NB. NOT _libdir
99 mkdir -p $RPM_BUILD_ROOT/usr/lib/rpm
100 install -m 0755 mingw32-find-requires.sh $RPM_BUILD_ROOT/usr/lib/rpm
101 install -m 0755 %{SOURCE5} $RPM_BUILD_ROOT/usr/lib/rpm
102
103
104 %clean
105 rm -rf $RPM_BUILD_ROOT
106
107
108 %files
109 %defattr(-,root,root,-)
110 %doc COPYING
111 %config(noreplace) %{_sysconfdir}/rpm/macros.mingw32
112 %config(noreplace) %{_sysconfdir}/profile.d/mingw32.sh
113 %config(noreplace) %{_sysconfdir}/profile.d/mingw32.csh
114 %{_prefix}/i686-pc-mingw32/
115 /usr/lib/rpm/mingw32-*
116
117
118 %changelog
119 * Wed Sep 24 2008 Richard W.M. Jones <rjones@redhat.com> - 26-1
120 - Begin the grand renaming of mingw -> mingw32.
121
122 * Sun Sep 21 2008 Richard W.M. Jones <rjones@redhat.com> - 25-1
123 - Add shared aclocal directory.
124
125 * Sun Sep 21 2008 Richard W.M. Jones <rjones@redhat.com> - 24-1
126 - Remove mingw-defs, since no longer used.
127 - Add _mingw_infodir.
128
129 * Thu Sep 11 2008 Daniel P. Berrange <berrange@redhat.com> - 23-1
130 - Add macros for find-provides/requires scripts
131
132 * Wed Sep 10 2008 Richard W.M. Jones <rjones@redhat.com> - 22-1
133 - Windows provides OLE32.DLL.
134
135 * Wed Sep 10 2008 Richard W.M. Jones <rjones@redhat.com> - 21-1
136 - Allow '.' in dll names for find-requires
137 - Windows provides GDI32.DLL.
138
139 * Fri Sep  5 2008 Richard W.M. Jones <rjones@redhat.com> - 20-1
140 - On 64 bit install in /usr/lib/rpm always.
141
142 * Thu Sep  4 2008 Richard W.M. Jones <rjones@redhat.com> - 19-1
143 - 'user32.dll' is provided by Windows.
144 - Allow '-' in DLL names.
145 - More accurate detection of DLLs in requires/provides scripts.
146
147 * Mon Sep  4 2008 Richard W.M. Jones <rjones@redhat.com> - 17-1
148 - Automatically add mingw-filesystem and mingw-runtime requires.
149 - Add --prefix to _mingw_configure macro.
150 - Three backslashes required on each continuation line in RPM macros.
151
152 * Mon Sep  4 2008 Richard W.M. Jones <rjones@redhat.com> - 14-1
153 - Fix path to mingw-find-requires/provides scripts.
154
155 * Mon Sep  4 2008 Richard W.M. Jones <rjones@redhat.com> - 12-1
156 - Put CFLAGS on a single line to avoid problems in some configure scripts.
157
158 * Mon Sep  4 2008 Richard W.M. Jones <rjones@redhat.com> - 10-1
159 - Provides certain base Windows DLLs (not literally).
160
161 * Mon Sep  4 2008 Richard W.M. Jones <rjones@redhat.com> - 9-1
162 - Include RPM dependency generators and definitions.
163
164 * Mon Sep  4 2008 Richard W.M. Jones <rjones@redhat.com> - 4-1
165 - Add _mingw_cc/cflags/etc. and _mingw_configure macros.
166
167 * Mon Sep  4 2008 Richard W.M. Jones <rjones@redhat.com> - 3-1
168 - Add _mingw_host macro.
169
170 * Mon Sep  4 2008 Richard W.M. Jones <rjones@redhat.com> - 2-1
171 - Add _mingw_sysroot macro.
172 - Add _mingw_target macro.
173
174 * Mon Sep  4 2008 Richard W.M. Jones <rjones@redhat.com> - 1-1
175 - Basic filesystem layout.