1499eb5f54ce2c298bbeae12e1ed9ab273c76d9d
[fedora-mingw.git] / expat / mingw32-expat.spec
1 %define __strip %{_mingw32_strip}
2 %define __objdump %{_mingw32_objdump}
3 %define _use_internal_dependency_generator 0
4 %define __find_requires %{_mingw32_findrequires}
5 %define __find_provides %{_mingw32_findprovides}
6
7 Name:           mingw32-expat
8 Version:        2.0.1
9 Release:        2%{?dist}
10 Summary:        MinGW Windows port of expat XML parser library
11
12 License:        MIT
13 Group:          Development/Libraries
14 URL:            http://www.libexpat.org/
15 Source0:        http://download.sourceforge.net/expat/expat-%{version}.tar.gz
16 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17
18 BuildArch:      noarch
19
20 BuildRequires:  mingw32-filesystem >= 33
21 BuildRequires:  mingw32-gcc
22 BuildRequires:  mingw32-binutils
23 BuildRequires:  autoconf, automake, libtool
24
25
26 %description
27 This is expat, the C library for parsing XML, written by James Clark. Expat
28 is a stream oriented XML parser. This means that you register handlers with
29 the parser prior to starting the parse. These handlers are called when the
30 parser discovers the associated structures in the document being parsed. A
31 start tag is an example of the kind of structures for which you may
32 register handlers.
33
34
35 %prep
36 %setup -q -n expat-%{version}
37
38 rm -rf autom4te*.cache
39 cp `aclocal --print-ac-dir`/libtool.m4 conftools || exit 1
40 libtoolize --copy --force --automake && aclocal && autoheader && autoconf
41
42
43 %build
44 %{_mingw32_configure}
45 make %{?_smp_mflags}
46
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 make DESTDIR=$RPM_BUILD_ROOT install
51
52 # Remove static libraries but DON'T remove *.dll.a files.
53 rm $RPM_BUILD_ROOT%{_mingw32_libdir}/libexpat.a
54
55 # Remove documentation which duplicates that found in the native package.
56 rm -r $RPM_BUILD_ROOT%{_mingw32_mandir}/man1
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61
62 %files
63 %defattr(-,root,root)
64 %doc COPYING
65 %{_mingw32_bindir}/libexpat-1.dll
66 %{_mingw32_bindir}/xmlwf
67 %{_mingw32_libdir}/libexpat.dll.a
68 %{_mingw32_libdir}/libexpat.la
69 %{_mingw32_includedir}/expat.h
70 %{_mingw32_includedir}/expat_external.h
71
72
73 %changelog
74 * Fri Feb  6 2009 Richard W.M. Jones <rjones@redhat.com> - 2.0.1-2
75 - Include license.
76
77 * Fri Oct 31 2008 Richard W.M. Jones <rjones@redhat.com> - 2.0.1-1
78 - Initial RPM release.