7492ba3a1f6d57e8c32b288f5df373960e6bf5f9
[fedora-mingw.git] / example / mingw-example.spec
1 %include /usr/lib/rpm/mingw-defs
2
3 Name:           mingw-example
4 Version:        1.2.3
5 Release:        1%{?dist}
6 Summary:        
7
8 License:        LGPLv2+
9 Group:          Development/Libraries
10 URL:            
11 Source0:        
12 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
13
14 BuildArch:      noarch
15
16 BuildRequires:  mingw-filesystem >= 21
17 BuildRequires:  mingw-gcc
18 BuildRequires:  mingw-binutils
19 # Any additional BuildRequires.
20
21
22 %description
23 # description
24
25
26 %prep
27 %setup -q
28
29
30 %build
31 %{_mingw_configure}
32 make
33
34
35 %install
36 rm -rf $RPM_BUILD_ROOT
37 make DESTDIR=$RPM_BUILD_ROOT install
38
39 # Remove static libraries but DON'T remove *.dll.a files.
40 rm $RPM_BUILD_ROOT%{mingw_libdir}/libfoo.a
41
42
43 %clean
44 rm -rf $RPM_BUILD_ROOT
45
46
47 %files
48 %defattr(-,root,root)
49 %{_mingw_bindir}/foo.dll
50 %{_mingw_libdir}/foo.dll.a
51 # etc.
52
53
54 %changelog
55 * Wed Sep 10 2008 Richard W.M. Jones <rjones@redhat.com> - 1.2.3-1
56 - Initial RPM release.