mingw64-filesystem package.
[fedora-mingw.git] / crossreport / mingw32-crossreport.spec
1 Name:           mingw32-crossreport
2 Version:        3
3 Release:        1%{?dist}
4 Summary:        Analysis tool to help cross-compilation to Windows
5
6 License:        GPLv2+
7 Group:          Development/Libraries
8 URL:            http://fedoraproject.org/wiki/MinGW
9 Source0:        crossreport.pl
10 Source1:        README
11 Source2:        COPYING
12 Source3:        crossreport.db
13 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
14
15 BuildArch:      noarch
16
17 BuildRequires:  perl
18
19
20 %description
21 CrossReport is a tool to help you analyze the APIs used by a compiled
22 Linux program, in order to work out the effort required to
23 cross-compile that program for Windows, using the Fedora MinGW
24 cross-compiler.
25
26 The simplest way to use it is to point it at an existing Linux binary,
27 and then read the generated report.
28
29 What it does in more detail: It looks at the libraries and API calls
30 used by the Linux binary, and compares them to the libraries and API
31 calls that we currently support under the Fedora MinGW cross-compiler.
32 It then works out what is missing, and produces a report suggesting
33 the amount of work that needs to be done to port the program.  For
34 example, whether whole libraries need to be ported first, and/or how
35 to substitute individual calls to work on Windows.
36
37
38 %prep
39 # empty
40
41
42 %build
43 # empty
44
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 mkdir -p $RPM_BUILD_ROOT%{_bindir}
50 install -m 0755 %{SOURCE0} $RPM_BUILD_ROOT%{_bindir}/mingw32-crossreport
51
52 # Install the database.
53 mkdir -p $RPM_BUILD_ROOT%{_datadir}/crossreport
54 install -m 0644 %{SOURCE3} $RPM_BUILD_ROOT%{_datadir}/crossreport/
55
56 # Install documentation (manually).
57 mkdir -p $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
58 install -m 0644 %{SOURCE1} %{SOURCE2} \
59   $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
60
61 # Build the manpage from the source.
62 mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1
63 pod2man -c "CrossReport" -r "%{name}-%{version}" %{SOURCE0} \
64   > $RPM_BUILD_ROOT%{_mandir}/man1/mingw32-crossreport.1
65
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70
71 %files
72 %defattr(-,root,root)
73 %doc %{_docdir}/%{name}-%{version}/COPYING
74 %doc %{_docdir}/%{name}-%{version}/README
75 %{_bindir}/mingw32-crossreport
76 %{_mandir}/man1/mingw32-crossreport.1*
77 %{_datadir}/crossreport/
78
79
80 %changelog
81 * Wed Feb 11 2009 Richard W.M. Jones <rjones@redhat.com> - 3-1
82 - Initial RPM release.