Move the source files into a subdirectory
[qemu-sanity-check.git] / src / Makefile.am
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644 (file)
index 0000000..823a7a2
--- /dev/null
@@ -0,0 +1,37 @@
+# Makefile for qemu-sanity-check
+# Copyright (C) 2013 Red Hat Inc.
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+EXTRA_DIST = \
+       qemu-sanity-check.in
+
+CLEANFILES = \
+       *~ \
+       qemu-sanity-check
+
+bin_SCRIPTS = qemu-sanity-check
+initrddir = $(libdir)/qemu-sanity-check
+initrd_DATA = initrd
+
+# Build the initramfs.
+initrd: init
+       echo $< | cpio --quiet -o -H newc > $@-t
+       mv $@-t $@
+
+noinst_PROGRAMS = init
+init_SOURCES = init.c
+init_CFLAGS = -static
+init_LDFLAGS = -static