Makefile: refactor detection and use of tools
[nbdkit-plugin-vddk.git] / nbdkit-plugin-vddk.spec
index aefec62..88fa9ac 100644 (file)
@@ -1,6 +1,7 @@
-# This is overridden when we call rpmbuild in the Makefile so you
-# don't need to set it here (unless you are not using the Makefile).
-#global vddkdir /some/path
+# You must set this to the directory where you downloaded VDDK.
+# NB. DO NOT PUT A TRAILING ‘/’ or you will get the error
+# ‘canonicalization unexpectedly shrank by one character’ on RHEL 7.
+%global vddkdir /home/rjones/tmp/vddk/vmware-vix-disklib-distrib
 
 # The minimum version of nbdkit that we can build/install with.
 %global minimum_version 1.1.2
@@ -10,7 +11,7 @@ Name:           nbdkit-plugin-vddk
 # NB: The Version field is parsed out of this file by Makefile, so it
 # can only be a simple number.  Also it must correspond to an nbdkit
 # released version (ideally the latest version).
-Version:        1.1.16
+Version:        1.1.19
 Release:        1%{?dist}
 
 Summary:        VDDK plugin for nbdkit
@@ -19,6 +20,8 @@ License:        BSD
 Source0:        nbdkit-%{version}.tar.gz
 
 BuildRequires:  nbdkit-devel >= %{minimum_version}
+BuildRequires:  perl-podlators
+BuildRequires:  gnutls-devel
 
 Requires:       nbdkit >= %{minimum_version}