aefec62de1d27c8466ceeafcbc7ec3ede1428b5e
[nbdkit-plugin-vddk.git] / nbdkit-plugin-vddk.spec
1 # This is overridden when we call rpmbuild in the Makefile so you
2 # don't need to set it here (unless you are not using the Makefile).
3 #global vddkdir /some/path
4
5 # The minimum version of nbdkit that we can build/install with.
6 %global minimum_version 1.1.2
7
8
9 Name:           nbdkit-plugin-vddk
10 # NB: The Version field is parsed out of this file by Makefile, so it
11 # can only be a simple number.  Also it must correspond to an nbdkit
12 # released version (ideally the latest version).
13 Version:        1.1.16
14 Release:        1%{?dist}
15
16 Summary:        VDDK plugin for nbdkit
17 License:        BSD
18
19 Source0:        nbdkit-%{version}.tar.gz
20
21 BuildRequires:  nbdkit-devel >= %{minimum_version}
22
23 Requires:       nbdkit >= %{minimum_version}
24
25 # Make sure the final package doesn't actually depend on the
26 # VDDK library.
27 %global __requires_exclude .*libvixDiskLib\\.so.*
28
29
30 %description
31 This package contains the VDDK plugin for nbdkit.
32 NB: it does not contain VDDK itself.  You have to download that
33 separately yourself.
34
35
36 %prep
37 %setup -q -n nbdkit-%{version}
38 %configure \
39     --disable-perl \
40     --disable-python \
41     --disable-ocaml \
42     --disable-ruby \
43     --without-curl \
44     --without-libvirt \
45     --without-zlib \
46     --without-liblzma \
47     --without-libguestfs \
48     --with-vddk=%{vddkdir}
49
50
51 %build
52 # Note we're only building the plugin, and we want to build it
53 # against the installed nbdkit.
54 pushd plugins/vddk
55 make %{_smp_mflags}
56 popd
57
58
59 %install
60 mkdir -p $RPM_BUILD_ROOT%{_libdir}/nbdkit/plugins
61 mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1
62 pushd plugins/vddk
63 %make_install
64 popd
65
66 # Kill libtool files with fire.
67 find $RPM_BUILD_ROOT -name '*.la' -delete
68
69
70 %files
71 %{_libdir}/nbdkit/plugins/nbdkit-vddk-plugin.so
72 %{_mandir}/man1/nbdkit-vddk-plugin.1*
73
74
75 %changelog