Update nbdkit:
[fedora-specs.git] / pixz.spec
1 Name:           pixz
2 Version:        1.0.2
3 Release:        1%{?dist}
4 Summary:        Parallel, indexed xz compressor
5
6 License:        BSD
7 URL:            https://github.com/vasi/pixz
8 Source0:        http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tgz
9
10 BuildRequires:  libarchive-devel
11 BuildRequires:  xz-devel
12 #Requires:       
13
14 %description
15 Pixz (pronounced 'pixie') is a parallel, indexing version of XZ
16
17 The existing XZ utils provide great compression in the .xz file
18 format, but they have two significant problems:
19
20 * They are single-threaded, while most users nowadays have multi-core
21   computers.
22
23 * The .xz files they produce are just one big block of compressed
24   data, rather than a collection of smaller blocks. This makes random
25   access to the original data impossible.
26
27 Pixz solves both of these problems.
28
29
30 %prep
31 %setup -q
32
33
34 %build
35 # Package doesn't use autotools, but honours $CFLAGS and $LDFLAGS.
36 # Adding -lm to LDFLAGS works around a bug in the Makefile.
37 CFLAGS="%{optflags}" \
38 LDFLAGS="-lm %{optflags}" \
39 make %{?_smp_mflags}
40
41
42 %install
43 # There is no 'make install' rule.
44 mkdir -p $RPM_BUILD_ROOT%{_bindir}
45 mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1
46 install -m 0755 pixz $RPM_BUILD_ROOT%{_bindir}
47 install -m 0644 pixz.1 $RPM_BUILD_ROOT%{_mandir}/man1
48
49
50 %files
51 %doc LICENSE NEWS README TODO
52 %{_bindir}/pixz
53 %{_mandir}/man1/pixz.1*
54
55
56 %changelog
57 * Wed May  8 2013 Richard W.M. Jones <rjones@redhat.com> - 1.0.2-1
58 - Initial package for Fedora.