Update nbdkit.spec.
[fedora-specs.git] / nbdkit.spec
1 %global _hardened_build 1
2
3 Name:           nbdkit
4 Version:        1.0.0
5 Release:        3%{?dist}
6 Summary:        NBD server
7
8 License:        BSD
9 URL:            https://github.com/libguestfs/nbdkit
10 Source0:        http://libguestfs.org/download/nbdkit/%{name}-%{version}.tar.gz
11
12 BuildRequires:  /usr/bin/pod2man
13 BuildRequires:  libvirt-devel
14 BuildRequires:  xz-devel
15 BuildRequires:  zlib-devel
16
17
18 %description
19 NBD is a protocol for accessing block devices (hard disks and
20 disk-like things) over the network.
21
22 'nbdkit' is a toolkit for creating NBD servers.
23
24 The key features are:
25
26 * Multithreaded NBD server written in C with good performance.
27
28 * Well-documented, simple plugin API with a stable ABI guarantee.
29   Let's you export "unconventional" block devices easily.
30
31 * Liberal license (BSD) allows nbdkit to be linked to proprietary
32   libraries or included in proprietary code.
33
34 Several example plugins are included in the package.
35
36 To develop plugins, install the %{name}-devel package and start by
37 reading the nbdkit(1) and nbdkit-plugin(3) manual pages.
38
39
40 %package devel
41 Summary:        Development files and documentation for %{name}
42 License:        BSD
43
44 Requires:       %{name}%{?_isa} = %{version}-%{release}
45
46
47 %description devel
48 This package contains development files and documentation
49 for %{name}.  Install this package if you want to develop
50 plugins for %{name}.
51
52
53 %prep
54 %setup -q
55
56
57 %build
58 %configure --disable-static
59 make %{?_smp_mflags}
60
61
62 %install
63 %make_install
64
65 # Delete libtool crap.
66 find $RPM_BUILD_ROOT -name '*.la' -delete
67
68
69 %files
70 %doc LICENSE README
71 %{_sbindir}/nbdkit
72 %{_libdir}/%{name}
73 %{_mandir}/man1/nbdkit.1*
74 %{_mandir}/man1/nbdkit-*-plugin.1*
75
76
77 %files devel
78 %doc LICENSE README TODO
79 # Include the source of the example plugins in the documentation.
80 %doc plugins/example*/*.c
81 %{_includedir}/nbdkit-plugin.h
82 %{_mandir}/man3/nbdkit-plugin.3*
83
84
85 %changelog
86 * Mon Jun 24 2013 Richard W.M. Jones <rjones@redhat.com> - 1.0.0-3
87 - Initial release.